• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


glennkelly

Budding Enthusiast
  • Content count

    45
  • Joined

  • Last visited

About glennkelly

  • Rank
    Settling In Well

Contact Methods

  • First Name
    Glenn

Profile Information

  • Gender*
    Male
  • Ford Model
    Focus TDCI 2.0 Titanium X Auto
  • Ford Year
    2015
  • UK/Ireland Location
    Bedfordshire
  1. At dealer. A relay module was changed yesterday and it’s -5° and going to do a cold start test on it. So they changed the relay and found Missing earth from BCMi. They have sent the data to Ford technical. The chief mechanics had the same fault or similar last week on another vehicle. So they are talking to Ford and he said he seems hopeful that this is the fault and need to get them Ford To pay for a new one under warranty. The car he changed it on was out of warranty but cost £500 to fix. It’s 100% not battery. So I just have to wait. He said he will update me later today.
  2. I asked for a new battery today and they said that the starting fault would happen every time if it were a duff battery - however I found this on web: A few years ago the original battery on my Focus was dying AND the alternator was getting a little tired, I started to progressively get the "steering assist malfunction" message more often, especially when the car has been stood for longer than 12 hours or it was particularly cold (both situation would have caused my battery charge to be lower). A new battery fixed the issue and I've not seen the error message again in the 2 years since the battery was replaced. I have more than one error message - and getting more and more frustrated and confused!
  3. Many of the below videos relate to the US Ford Focus, but they are very Very similar and relate to a faulty TCM Module. I wonder if this would be the case with my UK Focus? TCM Module (Transmission Control Module) : https://www.youtube.com/watch?v=Ma99lOynM1g https://www.youtube.com/watch?v=z9i71GOdeJY https://www.youtube.com/watch?v=O6BaR6lVp5k https://www.youtube.com/watch?v=kFc8x2aa0Kc
  4. UPDATE: I spoke to not only the dealership that sold me the car today but also to the tech who is working on the car at my local Ford Dealer. The tech named Gary who is working on my car and he said 100% its not the battery. If it was the issue would happen every time. He said its one of 30 modules on the “Canbus” which is faulty and he is having problems finding which one. So much so that he is talking to Ford's Technical people as he can replicate the issue when cold, and he said that the issue is really strange. Ive given them until Friday to resolve the issue. The dealer I purchased from phoned me today following an email and thus far have been good. They said in fairness to them I need to get the car to them for their tech to look at then take it from there should I need to reject the car. My understanding is that I am within my rights to give a Ford Dealership ample time to resolve the fault, If the fault cannot be resolved, then I am entitled to a refund of the vehicle less wear and tear, or a like for like replacement vehicle. I just want my own car back! Should I be hopeful I will get it resolved?
  5. Thanks andypsp - I will push for the battery. I really do hope its something as simple as that. Else I am worried how I stand with my warranty, seeing as its a car from Ford Direct purchased in January 2016 and which the manufacturer warranty ends in March. If they cant identify the fault - I need to find out what my rights are.
  6. Thanks andypsp - I will push for the battery. I really do hope its something as simple as that. Else I am worried how I stand with my warranty, seeing as its a car from Ford Direct purchased in January 2016 and which the manufacturer warranty ends in March. If they cant identify the fault - I need to find out what my rights are.
  7. So the car had a replacement Restraint Module. Picked the car up yesterday afternoon. All was well. Left the car an hour, and started fine. Left teh car for another 4 hours by which time it was -1 dogs outside and car didn't start. Same issue. Same again this morning.It eventually started after 10 minutes, so its back at the garage. It seems that when the temperature is warm(isa) it behaves. When cold it misbehaves.
  8. Update: Was told today that the fault has been identified as an Issue caused by a Airbag Restraints Module. A short circuit apparently throws the ECU into a fit and prevents the car from starting and throws up other errors. Part on order so should get resolved Thursday or Friday. See what it is in this You Tube Video. I'll update again when I hear from the garage. n