• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


Richo0

Budding Enthusiast
  • Content count

    4
  • Joined

  • Last visited

About Richo0

  • Rank
    Newbie

Contact Methods

  • First Name
    Richard

Profile Information

  • Ford Model
    Fiesta tdci zetec s
  • Ford Year
    2006
  • UK/Ireland Location
    Hampshire
  1. Is this a common problem then. ? Hoping it is just a hose.
  2. Just thaught id say hi, My names Rich from southampton and im currently driving a fiesta 2006 1.6 tdci zetec S. I have some problems with it that i need advice with, Wheres the best place to post it on the forum. ? Thanks and once again Hi . :)
  3. Hi everyone, Ive just purchased a fiesta tdci 1.6 zetec 6 about a week ago, And have had nothing but problems with it, I got all the injector seals replaced by Hendy ford in eastleigh southampton. And they also told me the glow plugs need replacing as this come up on the diag. However driving it last night the car felt like it went into limp mode but with NO LIGHTS on th dash. I pulled over opened the bonnett and the rubber hose/pipe coming from the bottom of the intercooler in to the turbo (i think ) was getting sucked in flat when the car was reved. Its the top part of the pipe going into something under the air box i think. Has anyone hear of this problem befor. I was thinking, 1.week hose and needs replacing. 2.blocked inter cooler 3. turbos Sh***d and needs replacing. The turbo does sound ok etc and i can hear it working. When the hose is sucked in there smoke what comes from exhaust and wont rev above 2000 rpm. Please help.
  4. Welcome to the Ford forums Richo0 :)