Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


john500

Budding Enthusiast
  • Content count

    6
  • Joined

  • Last visited

About john500

  • Rank
    Newbie

Contact Methods

  • First Name john

Profile Information

  • Ford Model streetka
  • Ford Year 2005
  • UK/Ireland Location Renfrewshire
  • Annual Mileage 10,001 to 15,000
  1. hi, fuel problem now solved, fitted new pump and now o/d flashing on my automatic 56 plate, gear change slow and erratic, any ideas what this means?? Thanks
  2. hi, my 56 plate mondeo 2.0 auto is not starting, checked the fuel pump and it had no voltage reading so replaced the fuel pump relay switch and after a couple of turns she did start, the next day nothing, guy came with a scanner and the code p0232 flared up, the secondry fuel sensor voltage is too high, any tips would be great..
  3. Heaters Only Blowing Cold Air

    thanks, can source these quite cheaply,,any ideas on fitting,,access etc..or is it one for mechanic, will give it a good flush also..
  4. hi, my 05 streetka has now starting blowing cold air from heaters, had her running for 20 minutes and put on hot but nothing, plenty of water and head gasket seems fine,,water does look a little dirty though,,any ideas or assistance would be great :)
  5. hi, roof now working, checked fuses and everything fine, windows still froze, any further suggestions??
  6. hello, looking for some help, my 05 reg streetka windows have stopped working and i have lately also noticed that the roof hatch at back is not opening when i press the button on the side.. are these connected or two seperate faults?? windows stopped working a few days ago and only tried the roof hatch button the other the day and there is nothing.. any help would be great.. :)
  7. Welcome to the Ford forums john500 :)