• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


Baz 2.0

Budding Enthusiast
  • Content count

    3
  • Joined

  • Last visited

About Baz 2.0

  • Rank
    Newbie

Contact Methods

  • First Name
    Barry

Profile Information

  • Ford Model
    Mondeo
  • Ford Year
    2004
  • UK/Ireland Location
    Leicestershire
  1. 2.0 Tdci Losing Power. Loss Of Power

    hi lee, ive got exactly the same problem. did you get it fixed and if you did what was the fault ? thanks baz.
  2. hi, i don't know if anyone can help me or give me a little advice . i have recently purchased a 2004 mondeo 2.0 TDCI 130 HP for a cheap reliable run about and everytime the engine gets warm the temperature gauge drops to zero and i lose most of its power. if i turn the ignition on and off it solves the problem for only a minute or so then it happens again etc etc. the engine management light also lights up on the dashboard. I have also checked the water level and everything seems to be ok there. i would be grateful for any advice from you guys because i do like driving the car and i would like to keep it. many thanks Baz.
  3. Welcome to the Ford forums Baz 2.0 :)