AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


tommygun

Budding Enthusiast
  • Content count

    9
  • Joined

  • Last visited

About tommygun

  • Rank
    Newbie

Contact Methods

  • First Name Tommy

Profile Information

  • Gender* Male
  • Ford Model fiesta 1.4 tdci
  • Ford Year 2004
  • UK/Ireland Location Lancashire
  • Annual Mileage 5001 to 10,000
  1. Fiesta 1.4 Tdci 04 Throttle Body

    Yes it is a very well know fault and it can be the pedal but i have had that changed it can also be the throttle body and where i think the throttle body should be it is not there on mine so think someone may have bypassed it or it is not meant to have one so to my next question should all 04 fiestas tdci models have the electrical throttle body or not ?
  2. I am having the eac fail problem with my fiesta 1.4 tdci someone told me it may help to check the throttle body for bad connections or clean it or even replace it my question is where exactly is it on the engine ?
  3. Fiesta 04 Tdci Eac Fail Help !!!!!!!!!

    Just noticed when i go to start the car if i do not depress accelerator pedal it will not start is this normal or could this be part of my eac fail problem all my other cars i have had will just fire up on the key with out touching the pedal !!!!
  4. Fault Code P0200 Eac Fail

    Have the eac fail problem tried loads of things up to now getting to the point of giving up changed numerous things pedal, throttle body etc etc still got the same problem as soon as i touch accelerator pedal get the eac fail and car goes into limp mode had codes read today by a very good garage had a few codes but all these cleared just left with one P0200 injector circuit malfunction which will not clear does this mean the loom that goes to the PCM wants changing ? if not does any one know what needs doing to rectify these problems help !!!!!! please !!!!!!!!!!! surely someone as had then solved this problem been on to ford main dealer today and spoke to a technician to see if they could shed any light on the problem,although he did say to fetch it in he also did not fill me with confidence he said they had one in last week with same problem the diagnostics pointed to the pcm after fitting a new one the problem was exactly the same not good as i say "Help"
  5. I have exactly the same problem as any one got to the bottom of it nightmare !!!!!!!!!!
  6. Fiesta 04 Tdci Eac Fail Help !!!!!!!!!

    Had codes read at another garage with better equipment a few codes came up but most of them cleared he said they where due to me unplugging stuff to clean connections. The only one that will not clear is P0200 injector circuit malfunction will this be what is causing my eac fail if so what can i do to rectify it
  7. Eac Fail....help

    I have the same ECA fail problem but mine is showing code P0200 injector circuit malfunction.Was wondering if you got to the bottom of your problem as i seem to be getting no where with mine just keep swapping parts for fun.
  8. Fiesta 04 Tdci Eac Fail Help !!!!!!!!!

    Changed the pedal where is the sensor ? is it not part of the pedal thanks.
  9. Hello everyone i am new to forum and hoping for some help.I recently bought a fiesta 04 1.4 tdci it was bought as seen so no going back. For the first few days every thing was fine then i got the eac fail flashing which sends it into limp mode i know this is something to do with the accelerator pedal i have done some reading up on it and basically it can be numerous things a friend as a code reader but no codes where stored.What happens is i go to start car in the morning while it is ticking over no problem but as soon as i touch the accelerator pedal it flashes the EAC fail message which means it is in limp mode so a can not drive it,if i leave it for a hour or 2 start it again no warning again on tick over till i touch pedal then same cycle again.So far i have changed pedal and cleaned every plug connection i can find with electrical cleaner which as not helped.Would really appreciate any advice on things i can try or advice on the cycle of the problem when and how it happens does this suggest 1 particular part is more likely to be at fault than another.Not keen on going to main dealer if they are going to suggest change that then change that and hope they get lucky if you know what i mean thanks to all in advance.