• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


Flynns60

Budding Enthusiast
  • Content count

    2
  • Joined

  • Last visited

About Flynns60

  • Rank
    Newbie

Contact Methods

  • First Name
    Simon

Profile Information

  • Ford Model
    Ford Focus Ghia
  • Ford Year
    2002
  • UK/Ireland Location
    Kent
  1. Thanks for your replies ! BTMALDON - where can i find the ICV or throttle position sensor ? JEEBOWHITE - yes, a brand new battery was fitted 2 weeks ago. So it starts fine, first time, with no long turnovers. I haven't put a mutlimetre across it but will give that a try...... JOHNH - which are the earth straps ? Thanks again
  2. Hi Wonder if someone can help. My car is a Ford Focus Ghia (2002) and sometimes when breaking & changing gear my battery light flashes on for a few seconds and the engine feels like its going to stall, but doesn't, and then the lights goes away. It's been happening very occasionally for while but is beginning to happen more frequenly. Two weeks ago a brand new battery was installed and i hoped this might resolve the problem but it's still happening and more alarmingly its happened twice whilst turning a corner and i've completely lost my steering - narrowly avoiding a crash on both occasions. Just wondered if anyone had any advice as to what might be the cause/possible solution ? Many thanks
  3. Welcome to the Ford forums Flynns60 :)