Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


JohnDavis100

Budding Enthusiast
  • Content count

    5
  • Joined

  • Last visited

About JohnDavis100

  • Rank
    Newbie

Contact Methods

  • First Name John

Profile Information

  • Ford Model Focus LX TDCi 1.6
  • Ford Year 2006
  • UK/Ireland Location Cardiff
  • Annual Mileage 10,001 to 15,000
  1. Hi Lenny Thanks again,but I don't have any clicking noise and the yellow engine management light was back on within 2 hours. The fault reading says egr frozen. So I am guessing that mine is beyond repair? I have priced them at euros and they are quoting £193 !! Just to check that the egr is supposed to be plugged in? I also notice that sometimes it can go a bit flat, through the gears, then will kick into life I am starting to get a bit annoyed with this car after a week of ownership, but I am determined to get to the bottom of it Thanks for your help and advice John
  2. Thanks Lenny Should I take the egr off and clean it with a bit of carb cleaner then put back together? Just to clarify,the ticking noise is when I am driving or is it just that the exhaust note is slightly louder and Diesel engine noises are more apparent ?? Thanks again John
  3. Hi guys Great post,followed the step by step and blanked off the egr of my Focus TDCI LX 2006. I had the red light appearing and it was kicking into limp mode,so I thought I would try this as the cheapest fix. The car drive great for the first 10 miles,before the yellow engine management light appeared and then it appeared to occasionally go a bit flat through the gears,then spring back into life. I took to my local garage and they plugged it in it showed a code of P420F I believe,which I think means egr stuck closed? They cleared it,the car drove fine again (also it may be in my mind,but the car developed a sort of pinking or ticking noise before the fault was cleared) and then last night,the yellow light reappeared. Any advice would be appreciated Thanks John
  4. Hi From Cardiff - 1St Day Of Focus Ownership

    Hi I picked the car up,all seemed fine,then it went into limp mode (red circle looking like a gear link with an I in the middle). Switched off and back on,seemed fine for 10 miles then same again!!! I have had the car serviced,they plugged in a reader but no fault codes stored,also had some dpf cleaner put into the tank and now having the egr blanked off It is 06 06 Focus TDCi 1.6 with 100k and FSH,no black smoke and runs lovely when not in limp mode So,not too sure Cheers John
  5. Hi all, I have just bought a Ford Focus TDCi 1.6 LX today. And after not a good 1st day, I think I may be chatting more with you guys,than I will be chatting to my wife. Regards John
  6. Welcome to the Ford forums JohnDavis100 :)