• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


Marty986

Members via FB
  • Content count

    4
  • Joined

  • Last visited

About Marty986

  • Rank
    Newbie

Contact Methods

  • First Name
    marty

Profile Information

  • Ford Model
    mondeo zetec s
  • Ford Year
    2005
  • UK/Ireland Location
    Down
  1. 05 Mondeo Starting Issues

    So here's an update; I had the mondy down at my Mechanic yesterday for a service and I mentioned about the starting problem, I got a call about 2 hours later say'n that he had opened the starter and it was full of shavings from the flywheel so he cleaned it out and now it starts 1st time again!! :) on the down side I need a new clutch thou :( but after 110,000 miles she's prob due 1
  2. 05 Mondeo Starting Issues

    No not yet have a service soon so gona ask if they would know anything, failing that ill have to get it plugged into ford & c??
  3. 05 Mondeo Starting Issues

    Not to sure what pats light is but all lights come on as normal with none flashing!?
  4. Hi I have a 2.0 tdci Mondy Zetec S & recently when I turn the key the 1st time, nothing happens no turn over what so ever but all lights are on as normal. I then turn the key to the off position & start again it fires up no problem! Any idea what the problem could be?? I am waiting for the coil light to go out every time b4 starting. I have also tried the spare key thinking the key could be worn but the same result. Any help would be great! Marty
  5. Welcome to the Ford forums Marty986 :)