• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


jamesozolins85

New Member
  • Content count

    1
  • Joined

  • Last visited

About jamesozolins85

  • Rank
    Newbie

Contact Methods

  • First Name
    James

Profile Information

  • Ford Model
    Fiesta 1.4 2007
  • Ford Year
    2007
  • UK/Ireland Location
    Monmouthshire
  1. Hi there everyone, I have a recurring problem with my fiesta zetec 1.4, 07 model. After servicing my car over four months ago which included changing the fuel filter I am frequently having trouble starting. The engine turns but no fuel gets to the engine. After pumping the fuel priming bulb for a while I eventually get it going but it has happened about a number of times now. Has anyone got any ideas of how I can remedy this problem? All suggestions would be appreciated. Cheers.
  2. Welcome to the Ford forums jamesozolins85 :)