Essex Boy Dave

Budding Enthusiast
  • Content count

    11
  • Joined

  • Last visited

About Essex Boy Dave

  • Rank
    Member

Contact Methods

  • First Name
    dave

Profile Information

  • Ford Model
    Ford Fiesta Zetec S
  • Ford Year
    2000
  • UK/Ireland Location
    Essex
  • Annual Mileage
    5001 to 10,000
  1. I don't know when fuel filter was changed
  2. Garage didnt clear the code
  3. no they said i needed a new 02 sensor i bought new one today cost 61.20 from eurocarparts put it on it runs better then wot it was but the full power still not there a bit so far iv put new coil pack... plugs // leads // fresh oil // fresh petrol // cleaned air filter etc gonna take it for a good run on motorway some point see if that helps might have !Removed! blocked in some where needs clearing i dont know :/
  4. I have a ford fiesta zetec s 1.6 16v 2000 model... It runs slightly lumpy on idle and lacking power on pull away.. Changed the spark plugs // leads // coil pack.. And still makes no difference... When I pulled spark plug leads of one by one and 1-3 engine drops when moved.. But closes one to coil pack when removed it does nothing or drop anything.. But seems to be ok on high revs only Pull away very sluggish Can anyone give me ideas what this could be coz I ain't got a clue
  5. Wot you mean
  6. tryed another coil pack and still doing same ?? any other idea peoples :(
  7. i dont think fuel was in it because when i picked it up had to put petrol in as was on emty , but i got a new coil pack coming monday for it and i put it on see if any change... i drove it back 70miles when picked up on motorway i was hitting 60 - 70 and it was running fine but when 1st 2nd gear just power not there dnt know but see wot happens when coil pack goes on new one ??
  8. thanks guys il grab a coil pack monday n i let you know if any change in it
  9. i give it a go thanks see if get any luck once put new swnsor on n good run
  10. it has a knn air filter and iv changed oil n stuff iv done all the basics what i could think of , do you think if i get new 02 sensor heater it will help or wont that effect the power n stuff ??
  11. Hello, i have a for fiesta zetec s 1.6 2000 model but iv got a bit of a problem the car was sitting for a year basiclly but i bought it yesterday, and when ni started it it was jump lumpy n the power was not there so i thought maybe spark plug n leads need changing so i bought new plugs and leads and is ticking over a bit better then what it was but the power was still not there but once u get in second gear n pick up speed it fine just in first gear... so i took it to a garage to be put on a machine n it come up 02 heater sensor would that make the car run like that n make it loss its power or could it be something else ?? please someone help i no good with fiesta iv just had bad luck with all fiestas lol Thanks Dave
  12. Welcome to the Ford forums Essex Boy Dave :)