AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Cat7

Budding Enthusiast
  • Content count

    2
  • Joined

  • Last visited

About Cat7

  • Rank
    Newbie
  • Birthday 05/05/1959

Contact Methods

  • First Name
    Graham

Profile Information

  • Gender*
    Male
  • Ford Model
    Fiesta Titanium X 1.0 125
  • Ford Year
    2013
  • UK/Ireland Location
    Staffordshire
  • Annual Mileage
    5001 to 10,000
  • Interests
    Motorsport & Racing

Previous Fields

  • Location
    Midlands
  1. Happy Birthday Cat7!

  2. Hi all, Titanium X 1.0 (125) 2013 Is there anybody else having the same issue with their stop start system? Air con - off Climate control - off Engine up to temperature. No heavy current drain equipment on. If you have the fan on its 1st setting and the temperature on the low setting, the engine refuses to cut out. If you move the temp up to 20 deg the engine will immediately cut out. These are obviously only low current drain so why would the above prevent the engine from cutting out? Confused, can anybody help. Cheers
  3. Hi all, (New member ) Had a Titanium X 1.0 Ecoboost for around 2 weeks now with just over 500 miles on the clock. So far the average mpg is around 42/43 mpg. A mixture of short to medium journeys, no motorways yet. The main reason for my post is the Ecomode option. From what others are saying, this is available and gives your personal economy performance. So far so good. My problem is that this Ecomode option is greyed out and cannot be selected. Anybody had similar issues? Cheers
  4. Welcome to the Ford forums Cat7 :)