Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


secretsquirrel

Budding Enthusiast
  • Content count

    4
  • Joined

  • Last visited

About secretsquirrel

  • Rank
    Newbie

Contact Methods

  • First Name James

Profile Information

  • Ford Model Ford Fiesta Ghia TDCi 1400cc
  • Ford Year 2008
  • UK/Ireland Location Berkshire
  • Annual Mileage 5001 to 10,000
  1. Auto Wipers Problem

    Anyone know where I can find the internal relay/fuse box for my wipers on my 2008 MK6 Fiesta?
  2. Auto Wipers Problem

    Awesome... where can I find this internal fuse box? is it not the one behind the glove box? Tried looking in the little book that came with the car but it doesn't mention anything about the internal fuse box... If one of the relays has gone is as simple as ordering a new one and pulling out the broken one and sticking a new one in? like changing a fuse?
  3. Auto Wipers Problem

    Ok... Going to sound awesomely daft... Is that the big box things that are above my fuse board which is behind my glove compartment or will it be somewhere else?
  4. Auto Wipers Problem

    Hi Guys, Need some advice with my Fiesta. I have a 2008 (08 Plate) MK6 Fiesta Ghia TDCi. There's a problem with my Auto wiper system where by if I click the stalk up one click to Auto/Intermittent it will activate the wiper blades up but then they stop half way through the cycle at the top of the windscreen but won't return to the bottom. But they will automatically return to the bottom to start a new cycles about 20 seconds later but then stop at the top again and so on.If i need to return them to the home position I have to pull and hold the stalk down til they return then let go... VERY annoying if i'm on the motorway and it's spitting with rain. But if the Auto wipers start doing a more regular rhythm i.e the program above intermittent they will work absolutely fine and you'd never know there was a problem and that's the same with any other program if I push the stalk all the way up to full power rapid wipe. It's very frustrating problem but can't work out what the issue is... I thought it could be my wiper blades sticking to the windscreen and then it just stopping so 2 days ago I bought brand new blades as they needed it anyway as old one were all frayed and split but it is still having the problem on the intermittent wipe... I have pretty much zero knowledge with car repairs or troubleshooting but I don't think it will be a motor program as it's working fine on all the other programs. I'm not sure if its like something as simple as a fuse or if I have to replace one of those black relay thingys somewhere! Please could anybody kind enough have a stab at this as I'm useless and can't afford to go to a garage and pay through the nose for them to investigate lol! Kindest Regards James!! :)
  5. Welcome to the Ford forums secretsquirrel :)