Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


WayneShears

Members via Twitter
  • Content count

    2
  • Joined

  • Last visited

About WayneShears

  • Rank
    Newbie

Contact Methods

  • First Name
    Wayne

Profile Information

  • Ford Model
    Focus LX 1.6
  • Ford Year
    2005
  • UK/Ireland Location
    Oxfordshire
  • Annual Mileage
    15,001 to 20,000
  1. Back of the net! I just guided Withington to play-off glory in League D2 http://t.co/fDG7nuiXfl

  2. Well, just had the garage back on the phone. They have had the car over a week and I had no contact since giving them the go ahead on the £700 repair. So I call them today and they tell me the fault they thought it was is not the issue, it is instead another part and this will cost £1000 for the part alone. I traded in an RX8 to buy a ford 2 years ago as it was more common and easier to fix and I thought more reliable. Since I bought this car 2 years ago it has been in the garage 6 times with various faults. Time to scrap it I think and buy a brand new car.
  3. Hi All, This is my first post here, so would like to say Hello first. I browsed this site a lot since purchasing my Ford, but never had a need to post, until now that is. So here goes. So, I have a Ford Focus LX (05 Plate), I have been getting error codes on the dashboard showing the check engine light. This happens but when you turn of the car and re-start the error code usually clears. I however was driving to work the other day and the car cut out and rolled to a stop. I then proceeded to try and restart the car, but nothing. The car has since been towed to the local Ford dealership who have informed me this is a fault with the Instrument Cluster and the immobiliser is therefore stopping the car from starting. The garage has quoted this work at costing in the region of £700. This seems a lot, so I was googling and seen this is a common fault on Ford Focuses and watchdog once covered this issue and Ford were fixing the issue for around £100. Please can you let me know if this is still the case and if there is a chance my car would fall in to the ones effected (as I am not sure which years/models have this fault)? Also how do I go about raising this with the Ford dealership, or should I try and contact Ford head office? Any help would be appreciated, many thanks.
  4. Welcome to the Ford forums WayneShears :)