AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.

Road Rob

Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About Road Rob

  • Rank

Contact Methods

  • First Name

Profile Information

  • Ford Model
    tdci zetec s
  • Ford Year
  • UK/Ireland Location
  • Annual Mileage
    0 to 5000
  1. Ok thanks, ive been looking into getting a repair kit but i guess if when I get the turbo off its more damaged than just the bearings then i'll have to get a complete unit
  2. Also I realise it has to be a vnt with pnumatic actuator and front mounted EGR but is this set up found on later cars and can I use one from a later model? And does it have to be a 130bhp like mine or can it be from a 115?
  3. I think I'm best finding one at a breakers rather than sourcing one online then I'll have a better idea if its a good one. Thank you for all your help and advice
  4. Its definitely a euro3 pneumatic EGR, it's just like the 1st illustration. The amount of play feels like more than 5 mm. It's woobbling all over the place.
  5. Hi FOCA and thanks for all the info. You will have to excuse my limited knowledge (i used to do all sorts with bikes and cars in my younger day but not any stuff with turbos) I am however keen to learn and if I can do it myself and save a few bob then I will! I've been reading up a bit and understand more about fixed and variable vane but not enough to know which mine is by looking at it. The EGR is located near the turbo as far as I can tell (you said some were front mounted?) There doesn't appear to be any splits in the pipe. I've just put it on the drive after limping home this morning and the smoke was worse than ever, took the hose off and the impeller has loads of sideways movement. Even I know this isn't good! You mentioned taking pics... I'm assuming I can post them on here? From what I've said would you say the turbo's definitely a goner? Thanks again
  6. Definite lack of power, white smoke and now its more of a screech than a rattle :-(
  7. Recently got a zetec s 130bhp. I've now noticed a noise that seems to come from the turbo, it started off as a bit of a whistle under acceleration which didn't sound too bad but its now a horrible sounding rattle. I'm praying its something simple but if anyone has an idea what it could be i would be very grateful. Good news or bad I need to sort this out! Thanks.
  8. Welcome to the Ford forums Road Rob :)