• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


dannymac900

Budding Enthusiast
  • Content count

    2
  • Joined

  • Last visited

About dannymac900

  • Rank
    Newbie

Contact Methods

  • First Name
    danny

Profile Information

  • Ford Model
    Mondeo
  • Ford Year
    2004
  • UK/Ireland Location
    Aberdeenshire
  1. hello, i have just joined the forums today searching for some help on my 2004, 1.8 mk3 mondeo i bought the car about 3 weeks ago and since buying it it has been shuddering under acceleration normally when i reach around 40mph mainly happens in 3rd and 4th and when i get fast enough in 5th that too....when i take my foot off the accelerator it stops, ive had it to my friend (mechanic) and he had a good look over the drive shafts etc and checked the wheels etc he finally diagnosed the problem as 1 of two things, 1. the pressure plate OR 2. the flywheel... atm i cant really afford to do either atm so have left it but just the other day i had noticed i was doing about 55mph in 4th with no shuddering it lasted a few days at that before retuning to normal...it has left both me and my mechanic stumped though he stll thinks clutch/gearbox/flywheel issues so i thought i'd take it to the forums and see if anyone could recommend anything atall *edit* the clutch is somewhat spongy though my friend thinks its because of bent fins on the pressure plate thanks alot in advance Danny
  2. Welcome to the Ford forums dannymac900 :)

    1. dannymac900

      dannymac900

      Thanks alot hoping to get some answers to my car problems