Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


tommydj70

Budding Enthusiast
  • Content count

    8
  • Joined

  • Last visited

About tommydj70

  • Rank
    Newbie

Contact Methods

  • First Name Thomas

Profile Information

  • Ford Model Ford Focus MK1 1.8 16v Estate
  • Ford Year 2000
  • UK/Ireland Location Essex
  • Annual Mileage 5001 to 10,000
  1. hi there I have a problem with my petrol pump when I put the car on second ignition sometimes the petrol pump will make a noise and car runs fine other times the petrol pump will not make a noise and the car starts and runs out of fuel iv done some testing but not to sure about the wires, I have taken the plug off the top of the pump under the back seats and put my multimeter on the ground wire and one of the other wires the thinkicker one of the bunch and when I turn ignition on I get 12volts for 2 seconds then it drops to 6volts and it stays there, this happen on every time I put the car on ingnition 2 is this correct 12volt then drop to 6volt plus does anyone have or know what are the pinouts for this connector so I can make sure im testing the correct wires, I don't want to get a fuel pump intill I am certain
  2. thank you for your reply. sorry iv had a close look its the inside handle that the clip has broken its the who part of the handle so im going to have to replace it
  3. ok this is what I have checked so far, checked fans are working, wired directly to battery this is fine, the fans do not work when engine gets up to temp, the fans do not work when I have the engine running and the air con on. apparently they should be on regardless of temp if the air con is switch on is this correct, I have checks all fuses, I found my way to the relays. I haven't replaced relays yet there are two located in the engine bay fuse box, I took one of the relays out and hot wired pin 3 and 5 in the box and the fans come on this relays was one nearest front of the car, i left the relay located nearest the front of the car out, i then removed the second relay and did the same shorted out pin 3 and 4 on the fuse box and the fans come on again, i cant see two relays being faulty but i will change them 2moro just incase, there must be something before these relays that tell the relays to click over the activate the fan im guessing the one of the relays is from the air con and the other relays is information from temp sensor were ever this is located yet to find, has anyone had this problem please don't tell me its ecu fault
  4. hopfully I can explain well enough, today I changed my electric window parts, this obviously involved taking the inner door handle off and door card on the drivers door, when I got to the point of putting the internal door handle back on to the door I some how managed to break the little platic clip thing that is attached to the door handle that goes into the frame of the door so that when you screw the electric windows housing back on the screw passes through that through the door handle and then into that platic bit that holds it tight into the door frame. what is this part called lol and were would I start to look or has anyone come up with a solution of fixing
  5. thanks for all the info,
  6. Hi im sure this has been asked before but I cant seem to find the topic anywere. i only have one key for my car, this key is really really worn so worn that a copy cannot be taken from it, it does not operate the doors anymore and ignition will soon follow im sure, iv never had the small tag that normally comes with keys from new, would ford give me this code if i took my logbook in free of charge so that i can go and get it cut, or is there somewhere on the car that this code is printed, hope one of you guys can help thanks,
  7. New Member

    Hi everyone, iv never been a ford fan but iv been converted slowly haha, I can see the attraction now lots of them so many parts floating around and very easy to repair, apart from fuse 64 think its called on the focus mk1, im sure everyone know what I mean that has had to change this one, iv just purchased a ford focus mk1 1.8 16v estate w Reg needs a bit of love common problems missing parts and niggle little electrical faults that im working through, and my girlfriend has a little 1.2 ka we have had for 2 years its 1998 model and never had a fault oh apart from worn spark plug lead lol im an ex Renault 5 owner so im sure working with fords is going to be much easier and a lot less problems, im an expert in changing head gaskets and turbo's lol.
  8. Welcome to the Ford forums tommydj70 :)

    1. tommydj70

      tommydj70

      thanks hopfully I can be a help and get helped on problems and faults , im as ex Renault owner used to fault finding lol