Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About bigdaz

  • Rank

Contact Methods

  • First Name

Profile Information

  • Ford Model
    mondeo 2.0 tdci
  • Ford Year
  • UK/Ireland Location
  • Annual Mileage
    0 to 5000
  1. ill have to do a nother leak of test is there aney way i can do a test or find out witch sylender has the diesel knock that would pin point a bad injector wouldent it ? could i do a home recon on my old injector it was prety bad filld leak of test in 1min 35 secons
  2. only wen it ticks over on its own then knock sencor bank 1 but it gows off if i restart it and keep driving and keep it above 1000rpm its fine all day if i do that but as soon as it ticks over on its own then i get my problem there only one knock sensor ??
  3. hi every one been triying to find suttin on the net but cant find nothing thats why im posting this lol right iv got a 2004 mondeo 2.0 tdci witch i need sum guidance with. fitted a new injector today as number 2 was shot so swaped and recded it runs like a dream but wen i stop in trafic the glow plug light flashes and the dreaded limp mode switch of and bk on all ok if i keep the revs on 1000k ish let it tick over on its own the light flashes got a knock sensor bank 1 fault .witch iv mounted off the block to eliminte a fault with a new one . it only cums on on tick over then the coil light flashes it runs verry lumpy but with no smoke and pulls well im a bit lost egr and inlet is spotles egr blanked off no splits in hoses .fitted a new cam sensor and fuel filter still the same .. i need a bit of help if aney one got aney sugestions please
  4. hi every one im new on here i got myself a right turkey here i swapped a car for a 2004 mondeo 2.0 TDCI yesterday 25.5.13 .and it nackerd test drove fine on the way home i put my foot down going up a steep hill and the heater plug light started flashing and it cut out started back up agen and the light kept flashing but with a major power loss and a lot of smoke got it home and left it 30 mins started bk up agen with no light on ran fine took it round the block a fyew times with black smoke noticed it happend wen the revs went over 3k.. switched it of and restarted it was ok untill 3k but now its on all the time with no power .. iv cleaned and blanked the egr. replased cam sensor checked pipes and chenged fuel filter .and heater plugs no joy wen im driving its smoking wight smoke all the time gets worse up the revs untill u cant c the car behind me but it sounds like a old diesel van verry nockey at 25k revs ... can aney body shed aney light on wat i may be ....thanks daryl theres no fault codes atall had a snap on reader on it
  5. Welcome to the Ford forums bigdaz :)

    1. bigdaz


      thanks steve hope people on here can help me i need help asap lol