AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About Lockys96

  • Rank

Contact Methods

  • First Name

Profile Information

  • Ford Model
    Fiesta titanium 1.4 tdci
  • Ford Year
  • UK/Ireland Location
  • Annual Mileage
    0 to 5000
  1. And I bet fords would have said they blower needed replacing.
  2. Magically sorted after pollen filter, can't believe it. Must have been the original 3year old one . Air back straight away and cost me £9 done myself
  3. Problem being its an ex lease car and purchased from well known bca I know the company however you would expect it to have been replaced at last service at 18000 miles.
  4. I'll take a look, the question is,'surely even if it appeared to be blocked should I get any air flow on the recirculate function.
  5. It just sounds like the air is trying so do the dash only, something is definitely preventing it, I'll ask a local garage I know tomorrow and see if they think a pollen filter could do this much I've only had the car for 2 weeks
  6. I think the dealer is making assumptions based on visually looking at it, mind you this is a salesman. I'm a bit hesitant to put it into the dealer. I can actually hear the blower working however there is no change in airflow. Is it unlikely that even if a pollen filter is blocked that you would expect some air to come through Is there something that would keep all the vents closed with everything else working? I've checked all fuses, guess I'm going to ask a local garage to look first as I have owned a lot of cars normally older with no problems like this Thanks
  7. Is this common or what, my car is 2010 April registered so is out of fords warranty by 1 month, the thing is its only done 23,000 miles also. I have No air flow. You can just feel the coldness but when you change from blower speeds and from say air to front to windscreen nothing at all happens. Ford say it could be the heater blower motor which would cost 500-600 to fix? Due to its location. Is this a common failure? My thoughts are that this shouldn't be failing I understand that it should need re-gassing but I don't think these parts should be failing alread. What is my best way forward from here? Has anyone had any problems with this Thanks Simon
  8. Welcome to the Ford forums Lockys96 :)