speedbirdab

Members via FB
  • Content count

    6
  • Joined

  • Last visited

About speedbirdab

  • Rank
    Newbie

Contact Methods

  • First Name
    Steve

Profile Information

  • Ford Model
    S-max
  • Ford Year
    2010
  • UK/Ireland Location
    Northumberland
  • Annual Mileage
    10,001 to 15,000
  1. rubbish isn't it? I'll get it serviced. The Galaxy did improve as the mileage increased - by 50k miles I was getting 50mpg on a run.
  2. Update.... As suspected, the Halfords/Bosch wipers are too short - went to Ford and got a pair of wipers for a surprising £17 after taxi driver discount (I'm not a taxi driver, but that's what they offered!) , the driver's one is about an inch longer and sweeps over the sensor - problem solved!
  3. Question to you please Recently purchased a 60 reg 2l diesel S-max, full service history etc. etc. I'm getting 39mpg around town and 41mpg on long runs - way below stated figures (not a surprise) but also way below what I got with my previous Galaxy - same size engine, same floorplan, same gearbox. Is this normal or does it need checking? Tyres are new and fully inflated, no scraping or friction sounds, aircon off, no roof bars or any drag items.
  4. I'll have to wait for it to rain again! I think the replacement wipers are 3/4 of an inch too short to sweep over the sensor - fine for normal use, but no good for auto setting...
  5. Just had Indespension fit a tow bar for £200 with no visible cut to the bumper. It works fine with my Mottez four bike carrier. The one thing to recommend is to have it removed before you sell the car - as the webuyanycar etc. will try to knock about £700 off the value of the car as 'it could have been towing something'...
  6. I don't know if others have had this issue, but the auto wipers on my s-max are a nightmare - you turn them on with any level of rain and they run a for a couple of sweeps then go to max speed and stay there - even with the finest drizzle! I've tried adjusting the wheel to the lowest or highest point or places in between but no better. The blades were replacement Bosch ones from Halfords - is there a chance they're not long enough to clear over the sensor?
  7. Welcome to the Ford forums speedbirdab :)