andyuk7

Budding Enthusiast
  • Content count

    50
  • Joined

  • Last visited

About andyuk7

  • Rank
    Settling In Well

Profile Information

  • Ford Model
    encore
  1. hi get your cat checked out as mines doing the same as mine loosing power when im driving and ive been reading on the net that my cats clogged
  2. on saturday i got the fuel filter and o2 senser chanced and i was out in the car today when i noticed it loosing power when i was in third gear so i took it on the motorway to give it a run and it got worse when i tryed going in 5th gear but the car just seem to loose power and the car stalled when i was idling can someone help
  3. hi ive just bought a new fuel filter and im having trouble getting it off as the nut is rusted on ive tryed taking it off with a allen key but i think ive rounded the head on it any ideas on how to remove it and the filter says line in is that the line from the fuel tank
  4. can anyone tell me if my fiesta has a engine managment light i own a 1996 fiesta encore
  5. ive just had my car in for a mot and it failed on high emmisions ive had the oil changed/filter and a new air filter put in i think its the oxgen senser does anyone know what socket it is ive a mk4 1996 fiesta and can i clean it
  6. ive noticed the car starts pulling to the right when i brake it happends when im slowing down for a high speed also i can smell burning and the front passenger wheel is very hot ive had new brake pads put in
  7. it was the breather hose i put it so ive put the old one back in and the car went back to normal no more stalling ticks over ok i think that there was too much air getting into the system and it was upsetting the cars routine it was the hose that fits on the oil cap on the edura engine
  8. plugs were a ok it all started off when i replaced a breather hose took it to a garage even them couldnt find out what was going wrong told me to book it in but dont want to spend a forture on something simple
  9. replaced the spark plugs and leads and the coil pack still having same problem car is ok to drive but it stalls when you slow down at a junction and keeps revving up when idle
  10. hi m8 i changed the idle control valve still didnt make any difference also changed the throttle sensor and that made it worse so i put the old one back in ill check the throttle housing today and ill put a new air filter in the car runs ok it just happends when its idling
  11. i have a mk4 ford fiesta 1.3 petrol and i got a majour problems with it the car doesnt idel proply and theres a put put noise from the exhaust i went to kwik fit to get advice from them and they said i needed new spark plugs and leads so i got them replaced but no difference so i went back to them and they said it was my coil pack so i had that replaced still no joy so i asked a mechanic and he he said it was the throttle sensor so i went to the scrap yard and got one and it made it worse as when i change down a gear it stalls it sounds like its missfiring from the exhaust
  12. ive recently changed my oil and rocker cover gasket on my fiesta and now i find that my temperature gauge stays in the cold position ive checked the thermostate thats working if theres a bad seal on the rocker cover would this cause the temp to stay in the cold
  13. my heater is blowning hot air out when its on the cold setting what can the problem be
  14. the cars 1996 its coming from the front drivers wing i think its the springs