AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Dazzl360

Budding Enthusiast
  • Content count

    9
  • Joined

  • Last visited

About Dazzl360

  • Rank
    Newbie

Contact Methods

  • First Name
    Dale

Profile Information

  • Gender*
    Male
  • Ford Model
    Fiesta Zetec S TDCi
  • Ford Year
    2010
  • UK/Ireland Location
    Yorkshire
  • Annual Mileage
    0 to 5000
  1. I had the same problem mate when my last car was written off. The other driver did not tell his insurance about the accident so i couldn't get a hire car or anything. I was fuming! Myself and my insurance reported the incident to his insurance a number of times, although to no good effect as nothing could be sorted until they spoke to the person involved. After about a week my insurance contacted me and said they could only proceed with the claim in around 3 more weeks, as they could do it without his consent 4 weeks (or so) after the accident. I was lucky as he eventually told his insurance in the end and it all got settled Hope this helps, and you get sorted!
  2. Sorted! Everythings working fine and back to normal now ive disconnected and reconnected the battery.
  3. Yes, The lights come on the wheel and dash as normal. Ive checked the fuses and they are fine. Im thinking the car needs re-setting so i might disconnect and reconnect the battery. Hopefully that will work.
  4. Ah right, not even the 'M' is working on mine. Thats why im thinking fuse. Ive found a list of all the fuses on the internet so ill check to see if anys tripped tomorrow. If not ill have to pop down to the dealers. Cheers!
  5. Hi all! This morning I replaced a broken 20AMP fuse as my 12v power socket was not working. The socket is now working again although ive noticed the audio buttons on my steering wheel are not. Can this be due to a broken fuse? If so which one and what AMP? Many thanks!
  6. Good news! Filled in the request form earlier and got a reply a few hours ago. They do have the part, its part number: 1539663 (<046C) You can only buy them as a pair, but there cheap enough. Saves buying a new shelf all together. Hope this helps for people with the same problem in the future Many thanks Dan!
  7. Will do mate, just been on that website but didn't see anything. Cheers!
  8. Hi Guys!! One of the clips has broken off my parcel shelf, it doesn't sit right anymore and the rattling is doing my head in. Has anyone else had the same problem?? Can you buy just the replacement clips or buy the complete shelf again? Many thanks!
  9. Welcome to the Ford forums Dazzl360 :)