Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


algie57

New Member
  • Content count

    1
  • Joined

  • Last visited

About algie57

  • Rank
    Newbie

Contact Methods

  • First Name
    alan

Profile Information

  • Ford Model
    mondeo
  • Ford Year
    2004
  • UK/Ireland Location
    Oxfordshire
  • Annual Mileage
    0 to 5000
  1. Hi all, new member here I own a 54plate Mondeo tdci 115. Recently the car has developed a problem whilst accelerating from about 2000rpm . The engine will suddenly lose power and the glow plug light will flash. If i kill the engine for a few seconds and restart the flashing light has gone and i'm able to drive , but no turbo. try the same procedure again , ignition off , on again and the turbo is there. Ive had the car on a diagnostic and have been told fuel pump {£1000} scary , i am aware that this error code is not always correct and it can be other things . Has anybody had this problem and can help point me in the right direction?? many thanks. ps the turbo is a pressure actuator not electric
  2. Welcome to the Ford forums algie57 :)