Mike_P

Budding Enthusiast
  • Content count

    6
  • Joined

  • Last visited

About Mike_P

  • Rank
    Newbie

Contact Methods

  • First Name
    Mike

Profile Information

  • Gender*
    Male
  • Ford Model
    Fiesta mk7
  • Ford Year
    2010
  • UK/Ireland Location
    Cambridgeshire
  • Annual Mileage
    Other / Non
  1. Couldn't find the photo sent to me, so took one myself, the 12V socket fuse is circled in the attached pic. I removed it and sure enough the socket stopped working, replacing it and all is fine.
  2. Thanks very much, it is now all working again simply by replacing the correct fuse. Cheers :)
  3. Interesting, the fuse indicated in that photo does exist in my car and is clearly blown, I shall get a replacement tomorrow and see what happens.
  4. I replaced (well added) the fuse in position 22, 4th row up 6th from left in that photo. Which is the cigar lighter/front power point according to the car's logbook. The one in the photo is stated as "Not Used" in the logbook, I shall see if putting a 20A their works. Thanks for the link :)
  5. Thanks for the quick replies. I was actually already using an existing fuse of the same rating, thanks for the help anyway. I may try and remove some trim pieces to get at the connection to the socket tomorrow. Alternatively I presume I could at least test the earth/neutral connection with a multimeter between the socket's neutral and the negative terminal of the battery. Thanks :)
  6. Hello, I have recently bought a 2010 Ford Fiesta Edge. The 12V socket (by the handbrake/aux socket) is seemingly not working. The fuse (passenger compartment no. 22) was missing, but replacing this with the correct 20A fuse didn't help at all. I have looked at the Haynes manual but can't find a suitable wiring diagram to search for the sockets earthing point etc. Any ideas as to what is wrong/what to check next? Not currently a huge problem, just bugging me having something that doesn't work Many thanks in advance, Mike
  7. Welcome to the Ford forums Mike_P :)