AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


bigjimmyauk

Budding Enthusiast
  • Content count

    11
  • Joined

  • Last visited

About bigjimmyauk

  • Rank
    Member

Contact Methods

  • First Name james

Profile Information

  • Ford Model leicestershire
  • Ford Year 2001
  • UK/Ireland Location Leicestershire
  • Annual Mileage 0 to 5000
  1. Completely dug out some paint while getting luggage out the car so thought I'd look at getting a bumper protector for the boot. I can not find anything that's fitted plastic. I don't want some flimsy film thing. Funny I'm sure these were 2 a penny but now they are eluding my search. If anyone can help locate one I'd very much appreciate it
  2. What Does This Belt Do

    Thanks for pointing me in the right direction. I've seen some people online saying it's the water pump but I don't think that's right looking at it. Apparently it's a 15 minute job to do at home. Half tempted to give it a try.
  3. What Does This Belt Do

    Car is a 2005 2.0tdci 130ps LX Just noticed the belt in the pics is cracking a little I have no idea what that belt does. Can someone tell me what it is and how much it would likely be to be replaced
  4. Mk3 2.0tdci Auxiliary Input Help

    I've got one :) rang them again after stripping it out and gave him the number off the side. He said yep we do this under a fiver including VAT. And your right it's not for a mondeo aparantly for other models but ford have it listed now as a generic ford multi model part . Baffles me how the first guy didn't know anything about AUX sockets.
  5. Mk3 2.0tdci Auxiliary Input Help

    Popped it off this morning. It is a genuine ford part but from what vehicle I have no idea. Never seen another mk3 with one in this location
  6. Picked up a 2005 2.0 tdci with FSH and a lot of history. Got a aux socket next to the gear stick and in the glove box. The one in the glove box works but the one next to the stick is had it plastic has broke and flopping around. Spoke to ford dealer and they are adamant the part don't exist. I just want to replace the socket. Any ideas or part numbers anyone can help with.
  7. 2001 Fiesta Heating Problem

    Used some rad flush and let it soak for half a day then flushed it backwards and forwards with the hose. Got no end of crud out of there. I got it clear to a stage where I could fill it with water from the top using a funnel when before I started I couldnt even get anything in there at all. I was looking aroumd to see if I could find the matrix capacity so I could check it's holding what it should.
  8. 2001 Fiesta Heating Problem

    Update. So today I completely re flushed the system and filled up with new coolant. Still no hot air. Water into the heater matrix is roasting hot and the return feed is onlu warm. If I disconnect the return hose I get a nice steady flow of hot water and warm air in the cabin as soon as I re attach the hose the air goes cold. Now that return pipe leads straight back to a branch in the bottom hose near the water pump. Is there a chance this hose could be.partially blocked thus not allowing a good flow through the matrix. Altho I thought if this was the case the engine would overheat. The only other thing I havent tried is completely bypassing the heater control valve and seeing what happens. Any suggestions at this point would be great as it's driving me crazy.
  9. 2001 Fiesta Heating Problem

    Right after a loss of heating to the other halfs fiesta I ran through the basics. Heater valve was faulty so replaced, discovered thermostat was stuck open so replacef that, flushed out the matrix and the rest of the system. Started the car and got only warmish air coming through. Checked for pulsating voltage at the heater control valve and all is good. Really I'm at a dead loss as to what else is stopping the car heating from getting warm. My other half wouldnt mind but shes just had a little one and I really dont want her driving it around in the cold snaps without heating. On a side note I've also bled the system best I could and believe all the air is out of the matrix and pipe work. Thanks in advance if anyone can help
  10. reversing light isn't working, check gearbox switch and wiring bulb connector is getting 12 volts when reverse is selected, ran a 12 volt led accross and works fine but attach a 5watt or 21 watt bulb and nothing happens. Also when you plug a bulb in you lose voltage down to zero between the 12volt switch wire and the earth. Anyone got any suggestions? Thanks :)