Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!


bod7

Budding Enthusiast
  • Content count

    5
  • Joined

  • Last visited

About bod7

  • Rank
    Newbie

Contact Methods

  • First Name
    Neil

Profile Information

  • Ford Model
    S-Max
  • Ford Year
    2006
  • UK/Ireland Location
    Hertfordshire
  • Annual Mileage
    5001 to 10,000
  1. To get to the wire he had pull back the wiring housing located between the door and the front end of the car. The wire had come apart from the connector at the point it re-entered the front end of the car. (hope that makes sense?) I only saw the broken connector, not the the actual point the wire reconnects. He was able to fix a new connector to the wire after spending a couple hours trying to find the fault. Good luck
  2. Turns out the connecting pin of one of the wires had snapped. Luckily it turns out I knew the guy at the garage and rather than having to buy and fit a new loom, he managed to replace the faulty one! Still cost £130 for the labour though as it took him a few hours to find the fault and replace dodgy wire. So is anyone is looking for an smax OSF control module, feel free to message me!
  3. Thanks for the replies. Tried disconnecting the battery but no good. I'm gonna book it in to garage and hope they can work out whats wrong. Hopefully it won't cost the earth!
  4. It's both the drivers and rear passenger door. The lights work fine, just seems to be the windows, central locking, electric mirrors and possibly the speakers.
  5. Hi, Hoping someone might be able to help. The central locking and windows no longer work on the drivers side of my 2006 S-Max. I've checked fuses, bulbs, wiring (as best I can), disconnected the battery for 30 minutes and even bought and fitted and new control module, but nothing has worked! Has anyone else had this experience? And if so, what was the cure??? I'm at a loss and loathed to take it in to a dealer if its a quick easy fix, but at the moment this looks like the only option! I'm a novice when it comes to the mechanics of cars, but im fairly competent and happy to have a go at the basics myself (although i'm fully aware of my limits!!) Many thanks in advance.
  6. Welcome to the Ford forums bod7 :)