Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


smudgeboy

Budding Enthusiast
  • Content count

    2
  • Joined

  • Last visited

About smudgeboy

  • Rank
    Newbie

Contact Methods

  • First Name
    Neil

Profile Information

  • Ford Model
    S-MAX
  • Ford Year
    2008
  • UK/Ireland Location
    Kent
  • Annual Mileage
    10,001 to 15,000
  1. In July 2013 I had a new fuel pump fitted to my 2.0 petrol S-Max (58 plate), a few days later the wiring loom was changed/fixed (I'm not sure the pump needed replacing - garage was reluctant to answer that question and didn't charge me for the loom work). 2 days ago had trouble with the car and I've just been told by the garage it needs a new fuel pump. This is all via the same main Ford dealer. Shouldn't new parts come with some warranty? If yes, is it only a year?
  2. About 3 weeks ago my 4 year old 2.0 petrol S-Max wouldn't start after a short trip in the evening (had been running fine during the day). Turn the key, and engine wouldn't start. Returned to the car the next morning and it started fine and ran ok during the day. Same thing happened in the evening. Returned next day and worked ok. Took my car to local Ford dealer and they did a health check and they claimed that the fuel pump was sticking and I would therefore need a new one, so booked it in for 4 days later. During those 4 days the car was fine. Fuel pump changed, wallet £620 lighter, car running ok. 2 weeks on, car seems sluggish and after stopping it won't start (fires and dies), appears to be same as initial problem. Call for recovery and the AA turn up 20 mins later (wow!) and sod's law - car starts! He checks a few things but can't find anything (and he's surprised that a new fuel pump was needed for a car with 32,000 on the clock) so agrees to follow me back to the Ford dealer. Within 1 mile of driving, car feels sluggish, no response from accelerator, so pull over and car stalls. AA man is behind me, checks things again, nothing wrong, car starts again! Same thing happens after about another mile. Pull into a petrol station and get some more petrol just in case (no fuel warning light, and suggests about quarter of a tank left). Then drive about 6 miles no problem. Leave car with dealer and next day get a call to say they took it out and experienced the same problem and after initially thinking they had installed a faulty fuel pump last time, they then discover 'high resistance' on the wiring loom, so they replace that (the loom) instead. Touch wood, car running ok now (interestingly, pulling away in 1st gear no longer 'judders'). I asked the question if the fuel pump really needed replacing first time around, i.e. could it have been the wiring loom all along, but the answer they gave seemed to be fobbing me off, so wondering if anyone has had a similar problem or thinks I may be right?
  3. Welcome to the Ford forums smudgeboy :)