Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


imjamesbtw

Budding Enthusiast
  • Content count

    23
  • Joined

  • Last visited

About imjamesbtw

  • Rank
    Member

Contact Methods

  • First Name
    James

Profile Information

  • Ford Model
    Ford Fiesta Zetec S1600
  • Ford Year
    2010
  • UK/Ireland Location
    Essex
  • Annual Mileage
    5001 to 10,000
  1. Cheers for your reply mate - will try and give it a go over the weekend!
  2. Hi everyone 60 reg Fiesta S1600 with 38K on the clock. Gearbox has recently started squeaking when changing gears - mainly 1st to 2nd & 3rd to 4th. Anyone else had this issue? Really annoying and only recently just started after being serviced by Ford. Gears are a bit stiff to change too but just put this down to it being cold. Cheers
  3. Hi everyone 60 reg Fiesta S1600 with 38K on the clock. Gearbox has recently started squeaking when changing gears - mainly 1st to 2nd & 3rd to 4th. Anyone else had this issue? Really annoying and only recently just started after being serviced by Ford. Gears are a bit stiff to change too but just put this down to it being cold. Cheers
  4. Power steering lock malfunctioned. Something to do with the keyless go. Had to have a new steering lock and keys re-coded. Bit of a joke for a 4 year old (4th birthday the day after it broke), 30k mileage car!
  5. Fingers crossed! Being towed to the dealership tomorrow so I will let you know!!
  6. Its electric power steering, so i hope its just blown a fuse somewhere!
  7. Popped to tesco last night, got in the car to drive off, push the ignition start button and the car beeps at me with a message on the dash saying 'steering malfunction, service now'. Then the whole thing goes dead and the ignition won't switch on. It's just out if warranty, done 30k miles, not due for a service for 3k miles. Recovery had to tow me home (so embarrassed), they checked the fuses, battery and no joy! Anyone had this?? Not a happy bunny!
  8. Anyone selling/know of someone selling a MK7 ZS Rear DIffuser with the exhaust cut out? Or... has anyone attempted to cut it themselves? Ta
  9. Hi everyone, Just a quickie - anyone else had this problem..... Start the car up from cold (even now when the weather is warm), pull away slowly and the car makes a whiney/whistling noise which is really annoying! The car is a 60 reg, only just done 30K miles so I'd be surprised if it was the exhaust system. The car gets used most days but only a short distance to the office so I guess it doesnt get a proper warm up. When the car is warm the noise doesnt occur. Just seeing if anyone else has had the same and what theyve done about it?! If its a normal Fiesta thing then I will just bare it. Cheers :-)
  10. Hi everyone, I finally got around to fitting the Asian Grill on my S1600! I know it looks pretty bland and basic in black, however I do prefer subtle asthetics :-P Have a good bank holiday!
  11. I'm going to give it a bash if I can get a rear diffuser with the cut out! Cheers guys, really appreciate it 👍
  12. Ah just realised you've got the newer zs than me - mine has 2 exhausts, just hidden under the bumper, so not sure how I'd get away with the tip you got. Let me know your thoughts and if I'm just being thick!! Looks really good though mate
  13. Cheers guys, didn't know you could do that, will check it out :-)
  14. Cheers mate, let me know!