Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Danz

New Member
  • Content count

    1
  • Joined

  • Last visited

About Danz

  • Rank
    Newbie

Contact Methods

  • First Name Dan

Profile Information

  • Ford Model S-Max 2.0 TDCI Zetec
  • Ford Year 2008
  • UK/Ireland Location Oxfordshire
  • Annual Mileage 0 to 5000
  1. Hello. I have a 58 plate S-Max 2.0 TDCI Zetec with a FSH on 75k miles. Recently, the Engine Malfunction Display came on accompanied by the ESP warning light and the car immediately switched to the get you home 'limp mode'. After I got home I turned the engine off then on again and all the warnings had gone. A few days later it happened again so took it to our local garage (not Ford) and they plugged it into a diagnostics machine and no codes of concern were stored and they said nothing was wrong. A week later it happened again so I took it to the Car Shop dealership I bought it from (with an extended warranty) and they once again put it through diagnostics. It threw up a code of P003A which equates to Turbo Charger Boost Control. Not being Ford specialists they have booked me into our local Ford dealership for further diagnostics. Has anybody had experience of this kind of fault before. I'm confused to be honest and don't know if the ESP warning light is telling me there is problems with the ABS Sensors or module, or if it is a bi-product of the engine going into limp mode and the true fault lies within the Turbo Charger Boost Control. Any views welcome.
  2. Welcome to the Ford forums Danz :)