Members via FB
  • Content count

  • Joined

  • Last visited

About WinDrop

  • Rank
    Settling In Well

Contact Methods

  • First Name

Profile Information

  • Ford Model
  • Ford Year
  • UK/Ireland Location
  • Annual Mileage
    5001 to 10,000
  1. Hi Guys, Thought to bump up this thread. What do you think, can the engine lose any power if there are bad pulleys and / or bad alternator? Will it somehow affect anything to do with the engine?
  2. Thanks Milton, Yeah, I am same as you. If I do change something I want to make sure that I change everything and that I won't have to look into that area again for quite a while. So if you do something - do it properly. I though that it might be normal for the clutch pedal to vibrate but I think that it is getting worst and worst. Not sure though... But as you said the clutch is connected to the engine and it might be that the engine is the one that's vibrating quite a bit hence the pedal is feeling same. Just wondering, can the engine vibrate because of bad pulleys and / or bad alternator belt? Is it possible that engine will loose any performance because of bad components in that area?
  3. Hi Guys, Hope you are enjoying this lovely weekend. I have few questions and I really hope that you will be able to answer them, or at least give me some hints and what to check. Basically by car is struggling to start if I do not press gas pedal while turning the ignition key. I have checked spark plugs and they seem to be absolutely fine. No signs of oil or petrol on them. Nice and dry. The plug wires and coil pack have been changed by the previous owner. So I assume that it was done around 12-15 months ago. Fuel injectors have been changed by myself around 4-5 months ago. I didn't bought them completely new but when I checked them in the garage I was told that the condition is perfect. I kind of don't believe that they could of gone that bad in such a short time... Now, I know that I have alternator problems and I already bought a new one and planing to change next weekend but could that really cause miss-fire? Another question is related to the alternator belt and all the pulley for it. I have found an alternator belt kit which costs £86 and it contains the belt and 5 pulley. Now, do you really have to change all the pulley? Is it worth it? The belt itself is in excellent condition but idler pulley is quite also gives me that squealing noise when I start up the engine. So I assume it's something I have to change. But is it really worth to change all of the pulleys? What's the point? Please see attachment for the kit and what pulleys are included in it. Third question is regarding the clutch pedal. When I put my feet on the pedal I can feel that it is vibrating. Sometimes it's just slight vibration, nothing serious, but then sometimes it goes mental. Now, my clutch never slips it always work absolutely fine it has also been changed around 5 months ago. When I changed it I changed clutch disk and slave cylinder. Is it normal for the pedal to vibrate? What could be the cause of it? What kind of tests I could run at home by myself to identify the cause of all 3 of these problems? Hope to hear from you guys. So far I have saved a fortune thanks to you guys. Kind Regards, Arturs.
  4. Thank you all for your help. I will try to change the alternator in next couple of weeks. Found some on ebay for £20-£30 and will ask my friend who is a mechanic to help me to change it. Thank you for your help.
  5. I tried to find some decent manuals online on how to change alternators but I couldn't find any. Could you please point me into the right direction? All I have done so far on my car is changed fuel injectors and spark plugs :) Nothing else really... =]
  6. So everybody still thinks that this might be an alternator issue. Problem is not in buying the alternator. Problem comes when you have to change it... =] I can get a new alternator for my ford focus for £70 but then I will probably pay something around £100 just to install it... Quite a costly job... :( Unless this is something a noob could do? o_O
  7. But then why when I tested the alternator it was showing 14.9V (with my heating and headlights turned on) instead of normal 14V-14.5V? It's even more than is required..So how can it still be alternator?
  8. Hi Guys. It's me again. Basically another problem with my car. As always don't know what exactly is wrong with it but have some ideas. So first things first. The symptoms. When ever car has heated up, basically after 5-10 drive, when ever I turn on A/C my car seems to loose quite a lot of RPM. First when I turn it on I hear a click, which I think is normal because the fan turn on, and then my RPM drops down quite a bit. Sometimes I even have the feeling that it will stall. Then of course after like 3-4 seconds it will pick up the revs but at the same second will drop again and so over and over again. This also happens when I turn on headlight, but it is not as noticeable as with A/C. This will also happen when headlight are on and I will turn the steering wheel, so power steering is in use. This is only happening while I'm idling. It obviously does not happen when I am driving as revs are usually 1.5-2K Another thing that happens when my A/C is on while I am driving is that when ever I switch gears I feel that strange "pulling" feeling. Basically an engine breaking feeling... This is also happening only when my A/C is on. However I have notices something similar when I am driving with A/C off at around 35-40MPH in 4th gear. As soon as I release gas pedal I have this same feeling again. First I though that this might be something to do with alternator so I checked it and it is actually overcharging at 14.9 instead of normal 14.5-14.6 which I think won't give any harm. Isn't it? Then after I checked the alternator I read couple of articles about idle valve control which costs around £25 on ebay and can be easy changed. But I don't really want to spend any money on it if it's not the case... So my car is a ford focus 1.6 Petrol (Zetec) Please let me know if you do require any more information and please forgive me if I haven't explained everything properly. English is not my first language. Kind Regards, Arturs.
  9. Right, Ok. This is really weird now... I installed new brake disks and pads today and also took a look at the CV Joint. CV Boot is not damaged, it's absolutely fine there. BUT!!! After I changed the brake pads and disks the knocking sound disappeared. I don't hear it anymore. How can this happen?
  10. Hi, I did a 50 mile journey today and found something very funny. I can hear the knocking noise only when I drive at around 15-35mph limit. If I drive faster or slower then that I will never hear the sound. I haven't actually took the wheel off, will do it tomorrow, but I'm just curious shouldn't drive shaft be knocking at any speed? When I was at MOT I was told that most likely it's the brake pad that knocks because it's at it's limit but I don't really believe that brake pad could knock like that... Any ideas at all?
  11. Once again. Thank you for the very detailed information. I will try to make some time tomorrow to actually lift the car up and take off the wheel so I can take a closer look at the CV Joint. Will also make some pictures so I can post them up here for you to take a look at them. I have been quoted £70 for a CV Joint replacement, the price is including labour. I think it's not that bad to be honest. But before I actually go for it I will try my best to inspect the Joint myself to see is it that or not. Once again. Thank you for the detailed explanation. Will keep you updated.
  12. Thank you very much for the detailed information. What can happen if this CV Joint won't get fixed? Can anything serious happen? Can I make long jorneys? I have to drive to the airport on saturday which is 60 miles one way. By the way. I'm already driving with this noise for about a week now. It doesn't really change. Doesn't get worst or anything. The funniest thing is that you can't hear it from outside. You can only hear it slightly from inside of the car. What could be the average price to change the CV Joint? Hopefully it's going to be less then 100 quid :) Also, If I will change it. Would you recommend to change both front cv joints at the same time? Just in case you know... Or there isn't really big point doing it? Thanks.
  13. Hi Guys, Damn I hate this car already...I do believe that previous owner never looked after it... Anyway, The problem that I have now is when I drive straight I hear weird knocking sound in my left wheel. It's not wheel bearing as I have changed that couple of weeks ago. So no chance that it's the wheel bearing. Funniest thing is that when I press the break pedal a tiny bit (maybe like 1cm or so...) the sound dissapears. Can it be something to do with the brake pads? I have passed MOT last week and one of the advisories for next MOT were brake pads and brake discs but not sure can they actually knock like that... It's not loud, it's only a little bit, and mainly when I drive straight. I have been told that it might as well be drive shaft. But I think that that knocks only when you turn the steering wheel till the very end. I have bought the brake discs and pads already as wanted to change them pure simply because they are advised to change for next MOT. But I would also like to know how to check the drive shaft. How can I find out what exactly is making that stupid knocking sound? Hope that you will be able to help me. Thanks.
  14. So you want to say that it's normal that when I turn on headlights my cars engine starts to struggle and starts to wobble (have a feeling that it will stall in a second...)I would totally agree if a/c would do this but headlights...c'mon...they are only light...they only depend on the battery. Maybe that could mean that battery is getting old and need to be changed? Arturs.
  15. Hi All, Hope all of your cars are running nice and smooth :) Couple of weeks ago I noticed that when I turn on A/C revs drop down from 900 to 800 (something like that...) which I think is normal...not sure but I think it's normal. BUT then couple of days ago I noticed that when I turn on my headlights the revs drop as well. They also drop down from around 900 down to 820-800 If in the first case with A/C I think it's normal then with the headlights it's quite odd...Isn't it? I can also notice that on my cars performance while I'm driving. It's not accelerating as fast and I can feel that the engine is struggling... When headlights and A/C are turned off cars runs nice and smooth, but as soon as I turn on one of them (or both) on that's it...that's the point where it starts to struggle. What could be the cause of this? And is the fact that revs drop down when I turn on A/C normal? Kind Regards, Arturs.