Pilgirm

Budding Enthusiast
  • Content count

    2
  • Joined

  • Last visited

About Pilgirm

  • Rank
    Newbie

Contact Methods

  • First Name
    Dan

Profile Information

  • Ford Model
    Fiesta 1.4 TCI 2010
  • Ford Year
    2010
  • UK/Ireland Location
    Lincolnshire
  • Annual Mileage
    10,001 to 15,000
  1. Hi, I recently Purchased a 1.4 60 plate ford fiesta in Blue, it had 36k on the clock and was running fine.i made a horrible mistake one day of mistaking the service and oil change light for the low oil level light (i know very stupid) and proceeded to put oil in my car, i unfortunatley overfilled it as the oil dip stick reciever was loose and wasnt fully showing how much oil was in the car, in fact it was saying there was none, so i thought it was low and overfilled it. i then turned the engine on and was halfway down the motorway and then my turbo blew and the seals on the turbo blew. ive had an aftermarket turbo fitted and there is a continious "judder" as the turbo kicks in around 40-50 MPH.. any idea on how to fix this? Also, the air conditioning unit is not working and ive been led to believe that it is the air con block that has blown due to there not being a wire or pressure relive valve on the compressor so it has blown the block off and ive lost the bolt and the two O-rings for the connection. again any ideas how to fix this or where to get the parts, i have a friend in work that can fix the air con and re-gas it but i need to get the bolt and the wire/valve for the compressor on the Air con.. Any help would be much appreciated. i dont know too much about cars so if you could put it all in lamons terms that would be even more gratefully sppreciated thanks dan
  2. Welcome to the Ford forums Pilgirm :)