lon

Budding Enthusiast
  • Content count

    13
  • Joined

  • Last visited

About lon

  • Rank
    Member

Contact Methods

  • First Name
    Leon

Profile Information

  • Ford Model
    S-Max 2.0 Titanium
  • Ford Year
    2009
  • UK/Ireland Location
    Somerset
  • Annual Mileage
    5001 to 10,000
  1. Well, found the problem. It's a tiny spring that pushes the ratchet in (see attached pic. There should be another spring end pushing that lever back). The e d had snapped off. Unfortunately, it doesn't look replaceable, and since it's partly responsible for making sure the handbrake stays on, I might have to replace the whole brake :-( I'd I can get the handbrake assemy out, I might see if there's a creative solution to be had. If so, I'll post here.
  2. just guessing really. I've never been a "car" person, but I used to be a cycle mechanic, and in general am quite handy. I will take it apart tonight and have a look, fingers crossed! I really don't believe the ratchet could have worn in such a short time - if it has I'm going to bet it's snapped, not worn. Interestingly, a bit of googling suggests that Ford recommend the button is only for releasing the brake, not applying it, and I read somewhere that it puts more pressure on the cable that goes to the button if you press the button as you apply the brake, which can cause that to fail sooner (the cause of the "brake won't release" problem that seems more common).
  3. strange that it went so suddenly. You'd think if the teeth were wearing, you'd feel it getting worse. The car's only done 51k. My (uneducated!) guess is that it's something like the spring gone in the ratchet, so it's not springing back and biting the teeth, but without taking it apart, no way to know. The handbrake mechanism is a big lump, and seems to cost a lot, so I really hope I don't need to replace it.
  4. why? It's got to be something related to the ratchet, surely that doesn't require an entirely new handbrake?
  5. pull the handbrake up, and the lever drops again. Putting something under the lever (3 cd boxes right now!) stops the lever dropping, and so the car is not moving (I gave it a push to check!)
  6. Hi all, I've searched the forum (and Google), and only found the opposite problem to mine... Driving into work today, my handbrake ratchet stopped holding. I just tried using it at a junction, and it didn't hold. The handbrake itself works, and so at work I've parked it in gear, and put a few CD's under the handle to stop it dropping back down again. I've seen plenty of issues where handbrakes are stuck on, but not like mine. Anyone else had this, and found a solution? Or anyone who knows the handbrake mechanism well enough to hazard a guess as to how it might be fixed? thanks Leon
  7. Sorry Supertomy - I saw your PM, but didn't get back. Can't seem to use this from my phone... Anyway, I did not ever get an answer, but to clarify, I have a standard USB socket in my glove box, no jacks, mini usb or anything. I'd love to find out if there's an answer. I also tried hooking up my old iPod, but it doesn't work. Only seems to work with never iPods and iPhones (tried with my Brother-in-Laws iPhone, and my wife's Ipod Nano (1st gen) which work, but my old clock wheel iPod doesn't.) Leon
  8. can anyone tell me if the current behaviour is normal? My wife is complaining about it - I've sort of got used to it. Best I can describe it, if you hit a bump in the road that would deflect the steering, it's effectively amplified by the power steering. Not so much that it would be dangerous, but it's a bit unnatural. certainly my old focus didn't feel like this, but I'm sure something I have driven before has felt like this.
  9. just like the one you can see in the vid here: http://www.ford-mobile-connectivity.com/downloadsUpdates when I press cd/aux, i get a "line in" screen, and I can select devices, but bluetooth is not listed.
  10. Hi all, I've seen a lot of discussions, but none seem to hit the mark, so apologies if I'm asking a well known question. Please give me a link instead of a snark (actually, both is fine ;) ) though if there is an answer out there! I have a bluetoooth voice control satnav stereo unit on my recently purchased 09 s-max. It has a USB port in the glove box, and a cd multichanger under the driving seat (in case it's relavent). I connected my Android phone, and the phone functions seem to work, but I can't find anyway to play music from the handset on the car stereo. I thought maybe it was a s/w issue, so I updated the unit software using the usb pendrive, but same result. If I read the manual correctly, it seems like it should be possible, but I can't find anything as helpful as instructions! So, my conclusion is that either: my phone isn't compatible (can anyone propose a compatible handset? I work in mobile so I have access to most that I could test with)I misunderstood the feature set, and it's just not possiblethe menu is so complicated, I just haven't stumbled on the right part yet.Any help would be greatly appreciated. Leon
  11. thanks jeebowhite - sounds a bit involved for me! I'll see if I get used to it first before I start mucking about with stuff like that. Interesting in the diesel v. petrol on here. My old car was a 1.8 petrol, but I just assumed that I'd seen the setting when test driving a diesel and forgotten about it. I think I set it when I first got the car (about 4 years ago), and forgot all about it until i got the new s-max. Old car was written off, so no way to check it now.
  12. ok, thanks! That will stop me cycling through every setting again
  13. Hi all, Just joined, as I just bought an '09 S-max Titanium, 2.0L petrol. One thing I noticed, is how "active" the power steering feels. I seem to remember this when I first bought a car with PS, so I'm not super concerned. I previously had a Focus Zetec, and that had a setting for PS, between Sport, Normal and Comfort, IIRC. I was looking around the menus, but couldn't find anything similair on the S-Max. Can anyone confirm if I should, or shouldn't have this, and where to find it? Thanks, Leon
  14. Welcome to the Ford forums lon :)