Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


pmustang

Budding Enthusiast
  • Content count

    2
  • Joined

  • Last visited

About pmustang

  • Rank
    Newbie

Profile Information

  • Ford Model
    2.0 TDCI mondeo
  1. She is in the shop now. I am thinking diesel pump, injectors or the warm start problem software that ford is supposed to be able to put into the computer to allow for wear in the system that causes this problem. Lets see what they say. I don't see it being a compression problem as the car cranks perfectly but is not catching, its got to be a fueling problem. Thanks. Peter
  2. Any help most appreciated. I have a 2.0 TDCI 2002 Ford Mondeo. The crank position sensor was changed about a year ago, the glow plugs about 6 months ago and now I have another problem. Car has 70k miles on it. The car started fine all winter in even the coldest weather. Now the car seems to want to start, I.E. it cranks perfectly and strongly but won't start. it usually takes about 10 times for me to get it to start, whilst at other times it starts first thing. I have found this issue normally after a decent lengths drive and then a quick stop, Say to get some lunch, Start her up in the morning, no problems, Drive to the supermarket and go in for ten minutes and come out and it does it, Any suggestion? I just don't want to get taken at the garage. I think it may be the injectors or the diesel cut off. Many thanks. Peter