AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About ianm2585

  • Rank

Contact Methods

  • First Name

Profile Information

  • Ford Model
    fiesta mk5 lx
  • Ford Year
  • UK/Ireland Location
  • Annual Mileage
    0 to 5000
  1. anyone know where to get a throttle cable for a fiesta mk5 1.25 zetec everyone suggesting at the moment it is a dealer only part
  2. maybe should have started a thread about wheel spacers or white dash dials gee what a forum
  3. have had a problem with revs hanging while changing gear had a look at the clutch pedal and the sensor has been removed , the socket is still there but no sensor how much would this affect the revs not being there. also measured my car today (2000 mk 5 zetec 1.25) the rear is 24 inch from floor to top of wheel arch and the front is 25inch, is it possible wrong springs have been fitted to the front from a different model fiesta not to concerned about this at the moment but the other two fiestas at work are endura engined and one sits 24 inch from the floor and the other 25inch the tyres are the same on both so it got me thinking whether different springs are in use
  4. mk 5 fiesta no engine light does anyone know what voltage should feed the light at the dash end i have the pin number and wire colour just looking for the input voltage. also light not working on the test mode either other question is if the led has gone is it possible to hook the feed into another warning light until a new cluster is found ie washer level.
  5. i have a 2000 w plate fiesta anyone here know off or use a obd reader that works for these
  6. i have a mk5 (w plate) 1.25 zetec with no engine light i tried the light test and no light comes on i removed the dash as i was going to swap the washer level bulb over but there appears to be no bulbs on the rear of the dash just the two top ones any ideas on this would be very welcome . also whilst in the test mode on the dash fault code 5967 appeared which i beleive is abs strange as not fitted to my vehicle any ideas on that welcome as well
  7. Welcome to the Ford forums ianm2585 :)