Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Tumbo

Budding Enthusiast
  • Content count

    7
  • Joined

  • Last visited

About Tumbo

  • Rank
    Newbie
  • Birthday 03/13/1949

Contact Methods

  • First Name Colin

Profile Information

  • Gender* Male
  • Ford Model Fiesta Titanium 1.4 TDCi
  • Ford Year 2012
  • UK/Ireland Location Norfolk
  • Annual Mileage 0 to 5000
  • Interests General Automotive
    Computers & Electronics

Previous Fields

  • Location Thetford
  1. Happy Birthday Tumbo!

  2. Reverse Sensors

    Thanks Tumbo
  3. Reverse Sensors

    Hello Nathan, That's perfect, looks great there doesn't it. I will feel confident to drill a hole in the dash now, Thanks for that. Wife took the car on her own for the first time yesterday and guess what? all went well. What is the display on the menu screen? don't recall seeing that before. Thanks again Naithan. Tumbo
  4. Reverse Sensors

    Hello Mike77 Thanks for the reply, not used to such things like ambient lighting ad I have already lost a bit of skin so, no worries there. Thanks again. Tumbo
  5. Reverse Sensors

    Hi all, I believe I sent this one to the wrong place originally, have found the site a bit confusing (getting old), got my my head round it now I think. Have fitted a set of reversing sensors to my 2012 1.4 TD is that a Mk 7? not sure. My question is about the little display unit, that I have at the moment sitting on my rear parcel shelf, was wondering if anyone had installed it on the the center of the dash just in front of the menu screen (where it looks quite at home and placed correctly does not obscure the drivers view) but would require a hole drilled into the dash, has anyone tried fitting it here? if so, is there easy access for the wire to come down to the fuse panel behind the glove box. I have tried getting my hand in but not far enough to feel under the menu screen although, I can only get my finger tips there but still am a few inches of where I would like to be before attempting to drill a hole. The sensor fitting went well thanks to the guides on this forum, would like to thank all of those that have taken the time to share their experiences. Finally I have noticed a dull redish strip of light on the edge where the glove box shuts to, can anyone throw some light (excuse the pun) on what this is for? doesn't seem to do anything and appears of no apparent use for anything but drain the battery. Thanks in advance for your help. Best Regards Tumbo
  6. Hi all, Have fitted a set of reversing sensors to my 2012 1.4 TD is that a Mk 7? not sure. My question is about the little display unit, that I have at the moment sitting on my rear parcel shelf, was wondering if anyone had installed it on the the center of the dash just in front of the menu screen (where it looks quite at home and placed correctly does not obscure the drivers view) but would require a hole drilled into the dash, has anyone tried fitting it here? if so, is there easy access for the wire to come down to the fuse panel behind the glove box. I have tried getting my hand in but not far enough to feel under the menu screen although, I can only get my finger tips there but still am a few inches of where I would like to be before attempting to drill a hole. The sensor fitting went well thanks to the guides on this forum, would like to thank all of those that have taken the time to share their experiences. Finally I have noticed a dull redish strip of light on the edge where the glove box shuts to, can anyone throw some light (excuse the pun) on what this is for? doesn't seem to do anything and appears of no apparent use for anything but drain the battery. Thanks in advance for your help. Best Regards Tumbo
  7. Newbie

    Hi all, Thanks for the warm welcome. Tumbo
  8. Newbie

    Hi all, Just signed up after reading about a guy who had battery problems as did I yesterday, he queried about a battery being charged at 13v, I had mine (Fiesta 1.4 TD) tested today and the alternator was charging at 13.5v. Back to hello, My name is Colin although I tend to use my old school nickname for user names these days 'Tumbo', now blissfully retired. I purchased a Fiesta Titanium 1.4 TD 5dr 62 plate 3171mls a couple of weeks ago, exchanging my immaculate 54 plate Toyota Corrolla I purchased new in 2004 and had only done 45,000 miles. I enjoy photography, WWII and modern day fighter aircraft and looking out the window at my little silver gem, married with two kids, I say kids both of them are turned 40 now with 3 grandchildren between them, Wife accepted of coarse they are my other three gems, am also a motor mechanic from the sixties, some technical details still prevail like wheels but other than that when I have cause to open the bonnet I shut it again very quickly these days. That's me. Happy whatever it is you do. Best Regards Tumbo
  9. Welcome to the Ford forums Tumbo :)