• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


Marko

Budding Enthusiast
  • Content count

    5
  • Joined

  • Last visited

About Marko

  • Rank
    Newbie

Contact Methods

  • ICQ
    0

Profile Information

  • Ford Model
    Ford Mondeo 1.8 TDCi Titanium X
  1. HELP QUICK!!

    Had to get Greenflag out. Good bloke called Dave managed to get in and sorted things out ... swore like a trooper though! Will be getting it into a Ford garage asap to get them to have a look at it. Cheers Mark
  2. HELP QUICK!!

    Just locked up my Mondeo 57 plate Titanium X. All of a sudden the alarm starts, lights flashing, the full works. Alarm has stopped, but hazards are still on, front lights on, radio blaring away to itself, main dash on?! Remote key fob doesn't work so cant open the doors / boot. The small metal key that comes with the remotes doesn't seem to work. Anyone got any ideas / know what the problem may be. If all else fails I'll have to call Green Flag out. Cheers Mark
  3. Cheers, Lets see how long I get out of these but will be keeping a close eye on the pressure, and booking in for a full wheel alignment asap. All the best Mark
  4. Hi I bought a 57 plate Titanium X last October (08) 2nd owner with low mileage. Since Feb 09 I've had to replace all 4 tyres which isn't cheap! I don't know if it's my driving style, although left my boy racer days years ago. The main wear seems to be on the inside of the tyre which cracks and disintergrates, and in the worst case the tyre came completely away from the inside of the alloy. Anyone any ideas / suggestion? Am I doing something wrong or is this something I just need to keep my eye on and make sure the tyre pressure is spot on. Cheers Mark
  5. ABS problem

    Hi. Please bear with me as I'm new to this forum stuff! My wife has a Ford Ka, about 5 years old. Very low mileage and only used for short trips. Recently the ABS warning lights have come on, and the garage we have used are suggesting a new ABS control unit is required ... at a cost of over £500!! Has anyone suffered the same problem, and can you offer any advice? Many thanks Mark