AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


caffeinehigh

Budding Enthusiast
  • Content count

    37
  • Joined

  • Last visited

About caffeinehigh

  • Rank
    Settling In Well

Contact Methods

  • First Name
    Chris

Profile Information

  • Gender*
    Male
  • Ford Model
    Focus
  • Ford Year
    2007
  • UK/Ireland Location
    Yorkshire
  • Annual Mileage
    0 to 5000
  1. Thanks Dan. So is it right that you need to use component for the front and coax for the back? Or are two sets of the same type going to sound fine?
  2. Thanks! I've been looking at the clips and bits on eBay so will pick some up. Looks like a tidy job! They fit in place just nice. Still not sure about the component / coaxial thing for front and rear but I'll do some reading.
  3. Excellent thanks. Final question guys. I've read I need 6.5" speakers front and rear. Component for the front and coaxial for the back (no idea what the difference is). Is that right? And does component/coaxial matter? If a bought two sets of these one for front and one for rear would they do the job?
  4. It took me quite a while to work out how to get the door panel off. It was rather fiddly! But now I've done it the other side should be ok. So long as I don't break any of the clips .
  5. Yes I believe so. My dad did the testing with his multimeter. I remember him mentioning resistance but can't remember what the reading was.
  6. Do you have a link? How do they fix in place once fitted on too?
  7. The rear speakers in my 2007 focus have never worked since I've owned it. My dad got his multimeter on the wiring today and tested it and wiring to the speakers seems fine. So I am presuming the speakers are blown. Can anyone recommend some speakers that will go in? I'm not looking to spend a fortune, just a set with half decent sound quality. By the looks of it you also need an adapter to raise the height of the speaker too?
  8. Can anyone recommend an aftermarket radio for the MK 2 that fits in nicely and kind of blends in. Main requirements are Bluetooth and dab that's about it.
  9. I've had two Focus now and both have made a slight metallic tapping at low torque, no idea what it is.
  10. Forte engine flush and a new oil filter on the way. Going to give it a flush this weekend. If that doesn't sort it I'm stumped. Saying that oil use seems to be down the last few weeks. No idea why. Still using more than it should though. Only thing different is I started filling up at shell. Doubt that would make a difference though.
  11. I watched this video and thought it was going to be harder than it was. To be honest we seemed to have more trouble disconnecting all the sensors and cabling than unbolting the manifold its self. Some of the bolts were a bit fiddly but with a range of socket extensions it was fine. I'd say within about 3 hours we had manifold off, PCV and hose changed, rocker cover gasket changed and manifold back on again and that included a stop for a brew and a bit of faffing about trying to remember where one of the pipes went back on. I can't remember the part number but I get things from Ford Parts UK. I usually email them with my Reg number and they confirm which one it is on their site.
  12. Bit of an update. Just changed the PCV, hose and rocker cover. The PCV still rattled when shook which I read means it's still good? The hose was a bit cracked and old but it didn't look like any of the cracks had gone through. So I'm leaning towards this might not have been my problem. Any of you guys know where the breather pipes are? I'm going to drop in some of the forte flush next week too and see. The flaps on the intake were quite gunked up. As was the metal bit the air filter connects to, forget it's name now. One other thing I noticed is there seemed to be a bit of oil in the very bottom of the air box.
  13. I'm getting through about a litre per month. I live fairly close to work too so I don't do a lot of miles in that time either.
  14. Thanks for the reply Peter. I've just tried out your suggestion and the card gets blown off quite heavily. So I guess something is blocked. I have the new PCV valve just waiting for the PCV hose to turn up as thought I might as well replace them both. Hopefully get it and the rocker gasket all changed next weekend.
  15. Yep no worries I'll let you know if I get it sorted. Might be worth having a look in your spark plug sockets see if you have the same sign as me. This is what my #2 spark plug socket looks like.