AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Aces

Budding Enthusiast
  • Content count

    2
  • Joined

  • Last visited

About Aces

  • Rank
    Newbie

Contact Methods

  • First Name Adam

Profile Information

  • Ford Model Focus 1.6tdci
  • Ford Year 2005
  • UK/Ireland Location West Midlands
  • Annual Mileage 0 to 5000
  1. Hey, thanks for the post. I'm not the most mechanically minded person in the world and it appears my first post was way off lol It's not the glow plugs, it's actually the fuel injector and it's not oil, it's diesel! Turns out, it's a very common problem with these cars. Number 3 injector seal starts blowing fuel and will eventually destroy the turbo as carbon gets into it. This was also the ticking noise I was hearing. Getting this done next week at ford and that should be the end of that. I think you're right about the battery, having that checked tomorrow and hopefully it's nothing more than that. Will update the post when I get news on it, thanks again for the post.
  2. Hey, new to the forums, apologies in advance if I'm posting this in the wrong place..... When I started the car this morning (focus 05 1.6tdci) I heard a clicking noise (like a plastic carton on a bicycle wheel) coming from the engine. When accelerating it got louder and completely stopped after about 15mins I looked in the engine bay and noticed a bit of oil on the glow plug third from the left Recently, upon starting, the headlights have flickered and the speakers have crackled a bit. Will this all be connected somehow? Any ideas? Annual service due next week