AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About bone1

  • Rank

Profile Information

  • Ford Model
  1. I thought that was the case with the thermostat. Yes I can hear the boot release click and the rear interior light comes on, exactly the same as when the button is pressed on the key fob. This normally happens when the car has just been started or after several minutes of driving when I come to a stop. I would have my foot on the brake but the boot doesn't open until stationary. Thanks for the comments
  2. I could do with a little help with a couple problems if anyone can help!. I have a 2005 (55 Reg) Ford focus TDCI 1.8 estate with 49k on the clock, When the weather is cold the water temperature takes around 8 miles or 20 minutes driving to start getting warm. The temp gauge goes upto around 75oC, however if I use the de-mister (fan) then the temp drops to around 60oC and it takes a further 20 minutes to get to normal temperature. I presume that the thermostat has stuck open, allowing water to flow through the rad continously. Does this sound like the correct diagnosis? The other problem is the boot release, I left the car for ten days whilst on holiday and when I returned the car started and ran with no problems, but when I stopped at the first junction the boot opened by itself. I got out the car and closed the boot. But at the next junction it opened again. This happened several times and then stopped. Several weeks later the problem was back , however this time the problem was worse and the boot kept opening continously until I removed the boot trim and unplugged the lock mechanism. I left the car like this for a day or so and when I plugged it back in the fault has gone again. :( Any ideas or comments would be greatly appreciated!! Thanks Bone1