Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


danyog1

Budding Enthusiast
  • Content count

    6
  • Joined

  • Last visited

About danyog1

  • Rank
    Newbie

Contact Methods

  • First Name
    Dan

Profile Information

  • Ford Model
    FORD FIESTA FINESSE
  • Ford Year
    2002
  • UK/Ireland Location
    Yorkshire
  • Annual Mileage
    0 to 5000
  1. I cleaned the face and plug of the coil pack and its now running perfect! thanks for all your help guys!
  2. I have renewed all 4 spark plugs and it is still doing it
  3. I cleaned the plug on number 4 yesterday and the car seems to have got worse.. the engine management light is flashing and the car has lost a bit more power.. Is this more reason to think its the plugs?
  4. I'll let you know the outcome of what part it needed
  5. Thanks guys!, I'm going to fix and sell the car now as the insurance is too much for what it is, I'm going to get a 1.6 ford focus tdci 110, That's only £2500 for insurance
  6. Hi. I'm a new driver and passed my test about 2 weeks ago.. since driving my car which has been in the family 5 years with no faults (Not even the engine management light has come on once).. it has done 99,000 miles and within 2 weeks I have done about 700-800 miles.. the engine management light has come on, I find it savage on fuel & it has become very sluggish. Last night when the engine management light came on I had done 200 miles that day the car was full 4 passengers and me, the car was very very low and was finding it hard to pull, once I dropped 2 people off the car was juddering until I reached over 30 mph and was running smooth at 60 mph. Today I started it about 2 times the engine management light went out and the car seemed to run much better,I tested the car out and did about 10 miles. The car also starts very slow now, it use to start first turn of the key. I did a check on the codes and 6 faults came back (Image attached) I cleared all codes and 3 are still there ( Image attached) While the car has been in the family since 2008 from the first day we got the car the petrol cap once released to fill up makes a whooshing noise. Any help I will grateful. Thanks, Dan.
  7. Welcome to the Ford forums danyog1 :)

    If you get stuck on how to post a question on the forums or trying to message a member then check out our video guides to help you get started!

    http://www.fordownersclub.com/forums/forum-0/announcement-47-how-to-use-our-forum-video-guides/