Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About fatsteve97

  • Rank

Contact Methods

  • First Name

Profile Information

  • Ford Model
    s max
  • Ford Year
  • UK/Ireland Location
  • Annual Mileage
    15,001 to 20,000

Recent Profile Visitors

655 profile views
  1. hi tom its 20l tdci the turbo stop working intermittently  the tester said turbo mechanical fault so the garage fitted a new turbo but still the same  

    1. TomsFocus


      Ok, it could be the turbo actuator at fault, damaged vacuum pipe maybe, or any of various sensors.  Really need to get the codes read if they haven't been already, you can do it yourself with Forscan on a laptop or smart phone.  Post the faults on the thread when you've got them.  :) 

  2. Hi had new turbo fitted still doesn't work properly any ideas
  3. hi thanks all have found the problem its the air con housing near the clutch pedal have tryed seeling it with mastic ill let you no how it goes
  4. hi thanks jeebowhite have found perished gromets on the sill hope this is the problem wait for more rain now wont be long
  5. hi all after all the rain at weekend i have found a lot of water in the driver's side front and rear footwells has anyone got any ideas thanks
  6. has my 20l tdci s max got a timing belt or chain
  7. no I mean where is the obd port located
  8. hi where do I plug my laptop in
  9. ok thanks have ordered one today
  10. hi jeebo no its like its like a few bumps at constant speed
  11. hi my 20l tdci s max pulls back when at low revs mainly when cruising at 60-65 I've had the latest pcm update it seemed to start 30 miles or so after the update been back to dealer but computer doesn't show any faults
  12. Welcome to the Ford forums fatsteve97 :)

    If you get stuck on how to post a question on the forums or trying to message a member then check out our video guides to help you get started!