Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Davidkent

Budding Enthusiast
  • Content count

    47
  • Joined

  • Last visited

About Davidkent

  • Rank
    Settling In Well
  • Birthday 08/20/1989

Contact Methods

  • MSN
    dakent89@gmail.com
  • ICQ
    0
  • First Name
    David

Profile Information

  • Gender*
    Male
  • Ford Model
    Mk1.5 Focus Zetec 1.8
  • Ford Year
    2001
  • UK/Ireland Location
    Wiltshire
  • Annual Mileage
    10,001 to 15,000
  1. Ah, coolant level is fine and it's still spotless clean so I can't see it being either damaged or blocked, will check that filter though. Thanks bud
  2. Ah I see, well worth a look then! Ill look shortly or this afternoon and have a go, any other possibilities? Thanks mate
  3. Ah wouldn't suprise me in honesty, I may check it first atleast, where is it? lol
  4. As above, My mum has been complaining about her heaters and from what research i can find, i'm not coming up with much. The blowers don't seem very powerful anymore, even when on full - Seems to be a different fault to that caused by a dodgy heater switch resistor, so i'm stumped here. Also, they only really seem to be blowing warm air, not Hot air - The temp guage on the car does go up, but i'm not sure whre its supposed to sit and so i'm not sure its correct or not, i also rarely drive the car so its hard to guage myself. Anyone have any suggestions? Its a 2006 '56' 1.8 TDCi model, i think its an LX if that makes any odds.. Thanks David
  5. It definitely has an M serial number on the top, but irrelevant really as the thing is most likely locked as well as being broken, eBay it will be I think tbh. Thanks for your help though mate
  6. Okay so only the mondeo ones vary to the Transit, fiesta focus etc etc? Are the codes generated using the same old type code generator too? I see the serial number is still the same format? Anyway, i think ebay will be my friend in this instance. Thanks for your help David
  7. Hi all, My uncle has not long bought a transit tipper on a 56 plate, and though the stereo headunit worked absolutely fine, the LCD Display never displayed anything - It always lit up but was just blank. Anyway, his battery went flat, and was replaced eventually, and now we can't get the stereo code in. Is there a lock process after so many attempts? Is there a way around this without being able to see the display? Can the Display be repaired? Alternatively, i've been looking online and can obtain another CD6000 Stereo that looks the same for around £50, though what i've heard is that they can be model specific, ie Mondeo ones won't fit in the focus and so on? Obviously its a late one on the Quadlock plug, just can't see what the difference is likely to be! He just needs a radio, its a working vehicle and drives us mad! Thanks David
  8. If its the pump, often they will pop the fuse - Replace the fuse and it'll pop again - Easiest way to tell whether it definately is the pump, though this may not be happening - Dependant on fault, thats just past experience
  9. Yeah i suffer all of these, as mentioned it was changed at 76k, approx 300 miles after the new speedo was fitted - Its covered almost 66k on the new speedo and here's the problem again, so that may well be it. Any idea of the part number and a decent place to buy the genuine part online? I don'd do ford dealers - Will obviously replace the pin at the same time. Thanks
  10. Focus's seem different to many cars however - Coilovers will be a Definate no due to price, but will be going springs. I want it pretty low, but currently its on 15's as standard, and though i'd like ST170 rims i can't afford. Any pics of how much 40 and 50mm looks? Cheers
  11. Re-Ebayed - Advice taken, looks like i need a speed sensor now anyway, AGAIN! Thanks guys :)
  12. I can do the job, but seems odd that it'd need another one - Box off soon for the clutch anyway, probably 5k's time Suppose its done 65k since, but didn't think that'd make it run funny however?
  13. As above, I've a Mk1.5 1.8 Zetec Model on a 51 plate. Its always had a very slight misfire type thing on idle, but its never bothered me, its done 142k but everything else is okay so far. However, on occasion, my speedometer (Just the speedo) Drops to Zero, and comes back within a few minutes, occasionally its longer and all the numbers go to dashes - However, when the speedo drops, i feel an almost instantaneous power loss - Its nothing drastic, though causes a more severe misfire and stalling on approach to junctions and stops etc etc. Are these problems likely linked, and what could they be? The car had a new speedo Cluster from Main dealer in 2008, followed 300 miles later by a speed sensor. Also, i'm unsure as to whether this is related, but when i change gear, or put my foot down on the clutch, the revs stick higher before dropping down again - I've been told this is common when the clutches near the end of their lives, and this could be the case, as to my knowledge, the clutch is original - Is this likely the case with this too? Its still returning a healthy 35MPG on Combined driving, so i don't feel these problems are anything to worry about, just something i'd like to fix. It was also serviced last weekend with Genuine Ford Plugs, Oil Fuel and Air filters, Pollen filter etc Any help much appreciated David
  14. Yeah can't afford coilovers and these came up reasonably, When you say problems, what kinda thing? Obviously the front springs on these are smaller so i can't see how they'd go into the struts properly in the first place tbh Was just hoping for something to make it low for a bit before returning to standard and so on Might just not bother infact, Any more on these though before i throw it out the window? Cheers
  15. Hey guys Just bought some half arsed coilovers really, They're more springs with adjusters tbh, ie no shocks or anything. Looking at fitting this weekend but can't find any guides or anything remotely close to what to do. Usually its all pretty straight forward, but this doesn't look it - I've got a box here with 4 springs, 4 adjusters, 2 C spanners as i'd expect, but there's then a whole load of rubber O ring Seal type things, and some grub screws. Anyone used these before? I only wanted something cheap, it'll probably only be a temporary thing anyway! Cheers all David