wikke

Budding Enthusiast
  • Content count

    3
  • Joined

  • Last visited

About wikke

  • Rank
    Newbie

Contact Methods

  • First Name
    wikke

Profile Information

  • Ford Model
    Fiesta Mk6 (UK Mk7) 1.6 TDCI DPF
  • Ford Year
    2011
  • UK/Ireland Location
    Other/NonUK
  • Annual Mileage
    5001 to 10,000
  1. Ok, as promised. I took it to the garage. They informed me that it was a faulty water pump. Supposedly, it also damaged the timing belt so they had to replace that as well. The noise is indeed gone now.
  2. Thanks for listening and the feedback guys. I'm taking it to the garage and I'll (try to remember to) report back what it was
  3. Hey all. i've recently noticed a strange sound coming from my engine of my 2011 model 1.6 TDCI (continental MK6, UK MK7 I think?). I even asked a friend who's a Ford car mechanic and he couldn't really tell what it was. So I was wondering if anyone here would mind having a listen. Car is 3 years old, has 30.000km (18.600 miles) and has undergone regular oil checks and maintenance. If you were to stand in front of the car facing it, it would come from the back left side of the engine. It's already audible after haven driven a few hundred meters. Still audible after 15-20 minutes of urban driving. Not really audible at higher speeds (probably drowned out)? You can hear a clip here, made while the car is stationary after driving for 20 minutes at modest speed: https://www.dropbox.com/s/oo5qhi2rr5ftboa/sound.mp3 I also attached it to this post. Thanks for any clues ! sound.mp3