• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


Daz P

New Member
  • Content count

    1
  • Joined

  • Last visited

About Daz P

  • Rank
    Newbie

Contact Methods

  • First Name
    Darren

Profile Information

  • Ford Model
    S-Max 2.0TDi Zetec
  • Ford Year
    2011
  • UK/Ireland Location
    Lincolnshire
  1. Radio Problem

    Hi, I got in the car this morning to go to work as normal radio working fine but then i actually looked at the radio and there was no display no light no power but the radio was working? I can operate it from the steering wheel but i have no function on the radio. The power on/off works but thats it. Its a Zetec on an 11 plate only a recent purchase the radio is a 6000. Do you think it could be a water ingress problem due to the bad rain we have been getting? Any help would be much appreciated. Daz