New Member
  • Content count

  • Joined

  • Last visited

About hugouyttendaele

  • Rank

Contact Methods

  • First Name

Profile Information

  • Ford Model
    fusion 1.4 durashift
  • Ford Year
  • UK/Ireland Location
  • Annual Mileage
    0 to 5000
  1. Hey guys, I'm a belgian owner of a 2004 ford fusion + with a durashift transmission, as the car has some simular problems regarding to not wanting to shift in gear and gear position indicator is going blank, i've been reading about the fixes over here. I've taken out the gear shift actuators as these can cause problems but the are not stuck, the plastic bushing was clean and the axle moved freely within. then i have opened op the electric motors to see if there was any problems, but the only thing i've found was dust from the brushes, witch i've cleaned out using compressed air. There is indeed a smal electronic board in it, also covered in dust. But this did not fixed the problem. At the same time i have opened up the complete wiring loom, checked it visualy and measured it out, but no corrosion or faults found. After these fixes i've put al the pieces back into the car and tried it out, no luck. Then i've taken out the clutch actuator, witch was not an easy task, and opened up the electric motor. the motor was covered in dust the carbon brushes, and after inspecting the rotor, i saw that the brushes are complete gone on one side, and not touching the rotor anymore. Does anyone know if there are replacement sets for these brushes for sale somewhere? Or does anybody knows where i can get this fixed? As i'm not sure that the rebuilders that you can find on the www are rebuilding the motors too, it seems that these are electronic repair techs. Sorry for my bad english, as it is not my native language.