Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


ukmole

Budding Enthusiast
  • Content count

    8
  • Joined

  • Last visited

About ukmole

  • Rank
    Newbie

Contact Methods

  • First Name Alan

Profile Information

  • Ford Model XR3i Cab
  • Ford Year 1986
  • UK/Ireland Location Other/NonUK
  • Annual Mileage 0 to 5000
  1. Mk4 Xr3I Cutting Out - Lots

    Panic over. I took off the distributor this am and Lo! an ignition amplifier underneath - covered in oil. I shall get a new one anyway and shield it some way from oil next time!
  2. Mk4 Xr3I Cutting Out - Lots

    Those with a manual: Is the Dizzie this model: MOTORCRAFT DISTRIBUTOR - EDA 329?
  3. Mk4 Xr3I Cutting Out - Lots

    So, it looks like my distributor doesn't have an external amplifier. Which means I have to get another one. There is one new FS on German Ebay for 145Euros! and a couple on UK Ebay second hand for 20quids-ish. Unless anyone on the liost wants to sell me one (working) with the external amplifier? @btmaldon: pic never came out! And I notice the system amended your 'advance and DELETED system'
  4. Mk4 Xr3I Cutting Out - Lots

    I could be the crankcase sensor. It cuts out without warning and needs a minute or five before it will start again. This last happened on Sunday and it did the cut-out thing for the five miles I drove home about twenty times! Where is the crankcase sensor?
  5. Mk4 Xr3I Cutting Out - Lots

    Here's a pic of the dizzy. I think it's a Bosch. Can't see anything attached except for a box where the LT wire goes in. Can you take a pic of yours if it has the Ford Ignition box attached? I see lots of them on Ebay, and they're all different!
  6. Mk4 Xr3I Cutting Out - Lots

    Had a look at my XR at the shop and I cannot see anything attached to the distributor. (Not that I know exactly where to look). My car is an '87 Cabriolet, so it should have one(?)
  7. Mk4 Xr3I Cutting Out - Lots

    Now we are talking! Well, at least (as you say) it's somewhere to start. I shall check and (possibly) replace and report back.
  8. First did it after an hours driving. Kept doing it every few miles/mins till I got it into a garage who installed a ballast as they said the coil was overheating. Well, this worked for at least two months. Now it's started doing it again. The current thinking is the distributor. Anyone else had/solved a similar problem? My XR is bog standard.