Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Mondeo2003

New Member
  • Content count

    1
  • Joined

  • Last visited

About Mondeo2003

  • Rank
    Newbie

Contact Methods

  • First Name
    Fred

Profile Information

  • Ford Model
    Mondeo Ghia X
  • Ford Year
    2003
  • UK/Ireland Location
    Berkshire
  • Annual Mileage
    Other / Non
  1. First post! I have a mondeo Ghia X 130ps TDCi Diesel (2003) . The car has served me well with 120k on the clock, but it recently has developed a bit of a problem which i'd love your help on. When driving in third/Fourth/Fifth gear, if I accelerate sharply the "glow plug indicator" starts flashing - In some circumstances it flashes AND the engine cuts out. However when i restart the engine, the flashing stops. No other problems, no black smoke, no other light flashing etc. A bit puzzled by this behavior and what I should do. No point getting the codes read as no light flashes after i've switched off the car. I'd like to keep the car, its a Ghia X and has served me well. Would appreciate any thoughts and if you need more information I can provide.