Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Swiftblade

Budding Enthusiast
  • Content count

    3
  • Joined

  • Last visited

About Swiftblade

  • Rank
    Newbie

Contact Methods

  • First Name
    Alan

Profile Information

  • Ford Model
    Mondeo Zetec
  • Ford Year
    2010
  • UK/Ireland Location
    Cambridgeshire
  • Annual Mileage
    30,001 to 35,000
  1. Hey all, Thanks for the great advice. I couldn't figure out how to disconnect the battery, so I removed the fuse instead and it worked! Now though I get an error about the stop bulbs! *sigh*
  2. Thanks for the advice, thankfully I do have the code! Will try this weekend, any thoughts on options if it doesn't work?
  3. Hi guys, Just joined as you seem to be a great resource for those of us that love our car, but don't know much about them! I'm wondering if anyone else has had an issue with the radio in terms of the Voice stalk and Aux button suddenly not working? I have a 2010 Mondeo Zetec and use the input via Aux to play music from my phone and regularly use the voice activated handsfree bluetooth function to make and receive calls. 2 days before my service I get these issues, the Ford garage say they can't fix it, its out of warranty so I need to replace the radio for £250+ Looked at other options, but the only viable one seems to be parrot which would allow the bonus of streaming music via bluetooth, but loses the voicecall function (and adds extra stuff in my car which I prefer not to, I prefer the tidy look). Does anyone have any other options? Can I force the Ford garage (whom I bought the car from in January 2012) to do something (ie, is this a known issue?). Really could do without spending £250 just to replace a radio, so any help gratefully received. Thanks in advance all. Alan