AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.

lll Rich lll

Members via FB
  • Content count

  • Joined

  • Last visited

About lll Rich lll

  • Rank

Contact Methods

  • First Name

Profile Information

  • Gender*
  • Ford Model
    focus 1.8tdci
  • Ford Year
  • UK/Ireland Location
  • Annual Mileage
    0 to 5000
  1. no i pulled over and managed to do a bodge job on it which lasted long enough to order the part and get me home in one piece lol which im glad it did as i live in a horrible place for cars but thanks again for your help p.s the first thing i notice what was wrong the other day was that my handbrake light was flickering really dim untill i braked and then it came fully on. But yes this was a very strange problem i thought it was going to be something much bigger. Thanks, Richard
  2. Hi, jeebowhiteProblem solved, as i had an idea of spraying my electrics with wd-40 i decided to give my cables a wiggle and i knocked my brake vacuum hose (by accident) and noticed it was broke. (NOT KNOWING WHAT THIS PART WAS FOR OF COURSE) i went for a drive to my local ford parts supplier and decided i will just leave this pipe off (REALLY STUPID IDEA) I got about 500m up the road before i realised i had no brakes and nearly smashed into another car, good job the lane next to me was empty :) i did not think the brake vacuum hose would cause all of them problems. Thank you very much for trying to help with my problem it is very much appreciated Thanks, Richard
  3. Thanks for the reply and the welcome. when this problem does not occur i still get boost and everything seems fine. sometimes when im pulling away or go up through the gears it seems like its misfiring and thats when i get the noise when the revs drop rapidly and i press a little harder on the pedal. if its just misfiring i thought maybe it has something to do with the electrics as it is now very damp weather and since i got this car i have fixed several faults regarding the electrics. thanks again for the reply Richard
  4. Hi, I have a focus mk1 1.8tdci and for the past 2 days my car seems to drop in power alot in all gears and when it does i can hear a loud grinding noise at the same time, it can drop in revs so much in 1st and 2nd gear that the car stalls. Any ideas? Thanks, Richard