Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!


Ben_ST200

Budding Enthusiast
  • Content count

    7
  • Joined

  • Last visited

About Ben_ST200

  • Rank
    Newbie

Profile Information

  • Gender*
    Male
  • Ford Model
    Ford Mondeo ST200
  1. Thanks, Found out the hard way and bought one from a after market place on sunday. £30 for spring for this car sounded too cheap.......and it was. I've got on order, and should be with today, hopefully. Thanks for you help. Ben
  2. Hi, I selling my beautiful ST200 to my friend and my luck has as usual shown me a clear example of what it can do and shot a coil spring through the tyre, the day before the new owner comes to pick it up! Nightmare! :( With it being a sunday, I can't get in touch with Ford directly as, no body appears to be home. (Thank you ford after sales). Now, I have manged to get hold of a aftermarket parts supplier who have a spring, however its listed as just a mondeo and not ST200. (The Size is 2.1 if that helps) My question is will a standard spring the same throughout the Mondeo mk3 group? IE Mondeo Zetec and ST200? My head tells me no and it's a main dealer job, but I just want to check with some gurus. Thanks, A very unluck Ben.
  3. 2nd time lucky. The TSB number is apparently an old number, dating back to 2001. It only applies to the Cougar like you said, but I assume they share the same guts? I find it suprising the ST200 didn't pop up! Cost of repair (not including part) is 60.48 +VAT I just need the part now! I'm tempting to let Ford loose with it and just get it done, or take it to a different garage. Apart from the obvious of flickering lights. Is there any damage this may cause if left? Also, just want to say thanks for your help. I would of lost without your skills and wisdom! Cheers,
  4. This is brilliant. You have described my problem right down. However I have called two ford dealers and gave them this part number and they inform me this doesn't exist. I have also checked the TSB number and they have no record of it. Is there anywhere else I might be able to get this cable?
  5. No they don't. I have had the alternator tested and the results were all ok. Start capacity was 98% voltage 12.61, regulator voltage 14.77 Haven't checked the connections yet, so it might not be earthing out properly. Anyone else have any thoughts? Thanks to everyone who has helped with there advice so far.
  6. Thanks Scottie, I'll have it looked into. From your desciption it is likely that is what it may be. On idle the lights are fine no activity and doesn't go on like a disco! but when reved up or driving it goes starts flashing away. Does this mean a new alternator if its over charging and under charging? Cheers,
  7. Hi all, I'm new to this forum as I have just an ST200. Have I made a mistake? Well it all depends on the answer to my problem I am having. It's birth was Sept 1999 if that helps. When driving with my lights on they appear to dim and brighten, in a sort of surge like way. I think it may be linked to my alternater, however the battery light doesn't appear. I wouldn't be bothered if it wasn't noticable, but it is! You could think I was flashing you out, which could be a real problem if i'm not careful! I havne't really noticed anything else other than it sometimes (less than often) jerks, but doesn't feel like a missing fire. Don't take a full on mechano dude, I have general knowledge to get me by, but thats about it. So, can anyone help me with my problem, and possibly provide a nice cost effective fix? Everyone knows you always go to look at a car during the day and not the night! Well, when it comes to this car I should of done both. Thanks reading, hope somone can help/advise and if your really feeling generous fix! lol Thanks again,