Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Iandb0812

Budding Enthusiast
  • Content count

    4
  • Joined

  • Last visited

About Iandb0812

  • Rank
    Newbie

Contact Methods

  • First Name
    Ian

Profile Information

  • Ford Model
    Mondeo TDCI Ghia
  • Ford Year
    2004
  • UK/Ireland Location
    Berkshire
  • Annual Mileage
    15,001 to 20,000
  1. Folks, Following on from previous thread I set about blanking off the EGR at the week end and cleaned out the inlet manifold and had or have a couple of issues now and I'm sure it's some thing I've done and hopefully easily fixed. Car is driving but has no guts to it at all and sounds like a 1970's transit van compared to how quiet it was before. Really struggling to get to and over 50mph Here is what's happened Some how managed to lose on of the manifold gaskets. When putting back on dropped it into engine bay. Initial thought was it went straight down the open EGR / intercooler hose. Eventually managed to get this off to check. but no sign so no idea where that went. replacement ordered found a nasty looking split in said hose (replacement also on order) not sure if it was always there or if I did it trying to get the damn thing off. Bottom clip was impossible to get to and had to remove where the hose clamps onto off the car frame underneath so I could get to it. Hopefully not done any damage doing thisSo as the car is now it is driving but with a missing gasket from the block and a large split in the hose, both parts are due to be with me tomorrow. There are no dash lights on (other than snowflake one but this has been on since I got the car) and other than the lack of power and sounding rough seems to be ok.
  2. Great, thanks all for the replies. Much appreciated :)
  3. Folks, Have been reading through as have issues with black smoke under hardish acceleration and when driving and with little acceleration the car jerks as if about to cut out. Took off and cleaned the EGR the other weekend and seems to have helped a bit and will be doing the inlet manifold this weeks end. With most of the reading I've done on here I've got myself a blanking plate but am being a complete thicko now :) where the feck does it go? On the pick below I've marked 3 things in red. I'm assuming the plate goes where the hose and chrome pipe in middle that comes across the front of the block? What do you do with this hose and pipe? Does it go back on with the plate?? Also is this the Intercooler pipe? Seen numerous post about checking for splits relating to my issues? Finally what is the small black hose on the left of the EGR next to the electrical connection? Thanks all